Installation process leaves a non-empty 'ns_temp2' folder in %TEMP% (== x:\WINDOWS\TEMP).

VERIFIED DUPLICATE of bug 212126

Status

SeaMonkey
Installer
--
major
VERIFIED DUPLICATE of bug 212126
15 years ago
12 years ago

People

(Reporter: sgautherie, Assigned: Sean Su)

Tracking

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5b) Gecko/20030827

I have seen this for multiple releases...
May be starting during the v1.4x cycle: possible "regression" !

W98SE behaves as W95B did.


Reproducible: Always

Steps to Reproduce:
1. (custom) Install Mozilla

Actual Results:  
'dir' output:
{
R‚pertoire de X:\WINDOWS\TEMP\ns_temp2

.              <REP>        13/09/03  11:18 .
..             <REP>        13/09/03  11:18 ..
XPCOM    NS    <REP>        13/09/03  11:18 xpcom.ns
         0 fichier(s)                  0 octets

R‚pertoire de X:\WINDOWS\TEMP\ns_temp2\xpcom.ns

.              <REP>        13/09/03  11:18 .
..             <REP>        13/09/03  11:18 ..
BIN            <REP>        13/09/03  11:18 bin
         0 fichier(s)                  0 octets

R‚pertoire de X:\WINDOWS\TEMP\ns_temp2\xpcom.ns\bin

.              <REP>        13/09/03  11:18 .
..             <REP>        13/09/03  11:18 ..
COMPON~1       <REP>        13/09/03  11:18 components
JS3250   DLL       330 832  13/09/03  11:18 js3250.dll
MOZZ     DLL        39 088  13/09/03  11:18 mozz.dll
NSPR4    DLL       173 200  13/09/03  11:18 nspr4.dll
PLC4     DLL        29 792  13/09/03  11:18 plc4.dll
PLDS4    DLL        25 424  13/09/03  11:18 plds4.dll
XPCOM    DLL       467 280  13/09/03  11:18 xpcom.dll
XPCOM_~1 DLL       123 440  13/09/03  11:18 xpcom_compat.dll
         7 fichier(s)          1 189 056 octets

R‚pertoire de X:\WINDOWS\TEMP\ns_temp2\xpcom.ns\bin\components

.              <REP>        13/09/03  11:18 .
..             <REP>        13/09/03  11:18 ..
JAR50    DLL        29 440  13/09/03  11:18 jar50.dll
XPCOM_~1 DLL        16 224  13/09/03  11:18 xpcom_compat_c.dll
XPINSTAL DLL       147 168  13/09/03  11:18 xpinstal.dll
         3 fichier(s)            192 832 octets

Nombre total de fichiers list‚sÿ:
        10 fichier(s)          1 381 888 octets
}

Expected Results:  
%TEMP% directory as it was before starting the installation.


Severity: major (unneeded use of disk space)
(Reporter)

Comment 1

15 years ago
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20030916] (v1.5rc1) (W98SE)

This directory is created after validating all the dialogs == during the
installation of the selected components == before the initial auto-launch of
Mozilla.

During this process, there is also a 'ns_temp1' directory created, which is
removed as expected; as the 'ns_temp' directory, created at the start of the
installer execution, is too.
(Reporter)

Comment 2

15 years ago
[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20030916] (v1.5rc1) (W98SE)

A 'ns_temp2' directory is also created during the uninstall process, and remains
there after the process completes.


[Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20030925] (v1.5rc2) (W98SE)

Same bug during install.
(I did not run UnInstall yet ;->)
(Reporter)

Comment 3

14 years ago
(As I recall)
The bug was already there in v1.4.

Comment 4

14 years ago

*** This bug has been marked as a duplicate of 212126 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey
(Reporter)

Comment 5

12 years ago
V.Duplicate, as reporter.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.