Installer should only delete Mozilla directory if previous version is of a different release

RESOLVED WONTFIX

Status

SeaMonkey
Installer
--
enhancement
RESOLVED WONTFIX
15 years ago
13 years ago

People

(Reporter: raccettura, Assigned: Sean Su)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: WONTFIX)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030912
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030912

Installer should only delete the directory (all the installed components), if
the release is a step (1.4 -> 1.5).  1.5 -> 1.5.1 (or 1.5b -> 1.5b) should not
prompt to delete components though should remain as a "clean install" option,
should someone wish to do so.

Reason being that to test nightlies, you have to reinstall potentially several
things for testing.

With releases, that means going up a x.x.1 incriment means quite a few steps.

What should happen is it should only happen for larger steps.  For all, you
should have the option to "Clean Install".  


End users don't want to perform more work than necessary.  Testers don't either.
 This is the third time this week I have to reinstall checky, since I can't seem
to update my installation without removing everything.

Reproducible: Always

Steps to Reproduce:
how Do you know that nothing changed in the nightly that needs a clean install ?
You should ALWAYS do a clean install as tester

Updated

14 years ago
Whiteboard: WONTFIX
Product: Browser → Seamonkey
This is an automated message, with ID "auto-resolve01".

This bug has had no comments for a long time. Statistically, we have found that
bug reports that have not been confirmed by a second user after three months are
highly unlikely to be the source of a fix to the code.

While your input is very important to us, our resources are limited and so we
are asking for your help in focussing our efforts. If you can still reproduce
this problem in the latest version of the product (see below for how to obtain a
copy) or, for feature requests, if it's not present in the latest version and
you still believe we should implement it, please visit the URL of this bug
(given at the top of this mail) and add a comment to that effect, giving more
reproduction information if you have it.

If it is not a problem any longer, you need take no action. If this bug is not
changed in any way in the next two weeks, it will be automatically resolved.
Thank you for your help in this matter.

The latest beta releases can be obtained from:
Firefox:     http://www.mozilla.org/projects/firefox/
Thunderbird: http://www.mozilla.org/products/thunderbird/releases/1.5beta1.html
Seamonkey:   http://www.mozilla.org/projects/seamonkey/

Comment 3

13 years ago
this won't happen until we have some way to deal with outdated components
resolving WONTFIX
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.