Ability to set SMTP and IMAP or POP password as the same when in the same domain

RESOLVED FIXED

Status

--
enhancement
RESOLVED FIXED
16 years ago
14 years ago

People

(Reporter: joseph.wright, Assigned: Bienvenu)

Tracking

Trunk
x86
Windows 2000

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030827

I use my work SMTP server to send e-mail where-ever I connect to the internet. 
That means I supply a username / password to send my mail - which I don't want
to save as it is also my network login password.

So, when I open up Mail, I supply my password for our IMAP server, then have to
supply it again when I send mail.  It would be nice if I could tell Mozilla that
the two have the same password as they are in the same domain:

smtp.soton.ac.uk and
imap.soton.ac.uk

Would it be possible to have an option "Use same password for each machine in
same domain", or something like that?




Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Updated

16 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: [RFE] Ability to set SMTP and IMAP or POP password as the same when in the same domain → Ability to set SMTP and IMAP or POP password as the same when in the same domain
(Assignee)

Comment 1

15 years ago
taking. We were thinking of doing this if the host name was exactly the same,
but that wouldn't help you...We'll probably make this controlled by a pref
that's initially turned off
Assignee: sspitzer → bienvenu
(Assignee)

Comment 2

15 years ago
Here's what I'm currently thinking:

We have two global prefs:
 smtp.usePasswordFromIdenticalHost, smtp.usePasswordFromSameDomain
and a per smtp server pref, smtp.server.serverx.usePasswordFromAccount
where the account value would be account key.

usePasswordFromIdenticalHost would interate over the incoming servers for one
with the same host name, and if it had a password use it.
UsePasswordFromSameDomain would iterate over the incoming servers for one with
the same domain name (everything after the first '.', so smtp.foo.com would
match mail.foo.com)

The Per server pref would look for the account with the same account key and use
the password stored in the server, if any.
(Reporter)

Comment 3

15 years ago
Sounds pretty much spot on.  Thanks
(Assignee)

Comment 4

15 years ago
Created attachment 140764 [details] [diff] [review]
proposed fix
(Assignee)

Updated

15 years ago
Attachment #140764 - Flags: superreview?(mscott)
(Assignee)

Updated

15 years ago
Blocks: 231959

Updated

15 years ago
Attachment #140764 - Flags: superreview?(mscott) → superreview+
(Assignee)

Comment 5

15 years ago
fixed on trunk
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Assignee)

Comment 6

15 years ago
*** Bug 93452 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 7

15 years ago
Here are the exact prefs:

+// if true, we'll use the password from an incoming server with
+// matching username and domain
+user_pref("mail.smtp.useMatchingDomainServer", false);
+
+// if true, we'll use the password from an incoming server with
+// matching username and host name
+user_pref("mail.smtp.useMatchingHostNameServer", false);

mail.smtpserver.smtp1.incomingAccount, "server1"); where server1 is the incoming
account you want to match (pop3 or imap)
(Assignee)

Comment 8

15 years ago
Created attachment 141125 [details] [diff] [review]
replace user_pref with pref

Scott pointed out that I used user_pref instead of pref - this fixes that.
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.