If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

trying to build errors reported with /usr/bin/unzip

RESOLVED INVALID

Status

SeaMonkey
Build Config
--
blocker
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Walter Literowich, Assigned: (default assignee for unassigned bugs. does not receive bugmail))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0)
Build Identifier: 

checking for autoconf... /usr/bin/autoconf
checking for unzip... /usr/bin/unzip
checking for zip... no
configure: error: zip not found in $PATH
*** Fix above errors and then restart with "make -f client.mk build"
make: *** [/usr/local/src/Mozilla-CVS/mozilla/Makefile] Error 1

but as you can see:

[root@walter1604 mozilla]# which unzip
/usr/bin/unzip
[root@walter1604 mozilla]# !w
which unzip
/usr/bin/unzip
[root@walter1604 mozilla]# ls -lat `which unzip`
-rwxr-xr-x    1 root     root       104588 Nov  4  2002 /usr/bin/unzip*
[root@walter1604 mozilla]# gunzip --v
gunzip: option `--v' is ambiguous
gunzip 1.2.4 (18 Aug 93)
usage: gunzip [-cdfhlLnNrtvV19] [-S suffix] [file ...]
 -c --stdout      write on standard output, keep original files unchanged
 -d --decompress  decompress
 -f --force       force overwrite of output file and compress links
 -h --help        give this help
 -l --list        list compressed file contents
 -L --license     display software license
 -n --no-name     do not save or restore the original name and time stamp
 -N --name        save or restore the original name and time stamp
 -q --quiet       suppress all warnings
 -r --recursive   operate recursively on directories
 -S .suf  --suffix .suf     use suffix .suf on compressed files
 -t --test        test compressed file integrity
 -v --verbose     verbose mode
 -V --version     display version number
 -1 --fast        compress faster
 -9 --best        compress better
 file...          files to (de)compress. If none given, use standard input.


this is on a :
Linux walter1604.dhis.org 2.4.21-0.13mdk #1 Fri Mar 14 15:08:06 EST 2003 i586 
unknown unknown GNU/Linux



Reproducible: Always

Steps to Reproduce:
1. make -f client.mk build
2.
3.

Actual Results:  
see above ....

Expected Results:  
that that would build properly

Comment 1

14 years ago
zip and unzip are two separate binaries (at least on my distro, which is Red Hat
9). What's the result of "which zip" on your system?
Summary: trying to build errors reported with /usr/bin/unzip → trying to build errors reported with /usr/bin/unzip
(Reporter)

Comment 2

14 years ago
see my original notes"
which unzip
/usr/bin/unzip
[root@walter1604 mozilla]# ls -lat `which unzip`
-rwxr-xr-x    1 root     root       104588 Nov  4  2002 /usr/bin/unzip*
[root@walter1604 mozilla]# gunzip --v
gunzip: option `--v' is ambiguous
gunzip 1.2.4 (18 Aug 93)

Comment 3

14 years ago
This is not a bug.

zip and unzip are two *separate* tools. On every (or so !) linux distro, you
have to install both :)

2.4.21-0.13mdk => MDk 9.1.

Let's see here (one of MDK mirrors) :

ftp://ftp.lip6.fr/pub/linux/distributions/mandrake/9.1/i586/Mandrake/RPMS/

Looking for "zip" (using ctrl+f) gives :

1) zip-2.3-9mdk.i586.rpm  	123 KB  	08/01/2003  	00:00:00
2) unzip-5.50-4mdk.i586.rpm  	238 KB  	08/01/2003  	00:00:00

So, check if you have both :)

Having unzip doesn't mean you automatically have zip installed.

Closing bug as invalid ?

Comment 4

14 years ago
Forgot to add that bug is when configure is trying to find zip file, as he found
previously unzip.
(Reporter)

Comment 5

14 years ago
Yes you are right  --  
zip-2.3-9mdk.i586.rpm  	123 KB  	08/01/2003  	00:00:00
was not installed but the error from configure was  ..  with ( unzip)

I am get further   

However now I get  

checking for gtk-config... no
checking for GTK - version >= 1.2.0... no
*** The gtk-config script installed by GTK could not be found.
*** If GTK was installed in PREFIX, make sure PREFIX/bin is in
*** your path, or set the GTK_CONFIG environment variable to the
*** full path to gtk-config.
*** GTK+ is available from ftp://ftp.gtk.org/pub/gtk
configure: error: Test for GTK failed.


And 
[root@walter1604 rpm]# rpm -i gtk+2.0-2.2.1-2mdk.i586.rpm                       
package gtk+2.0-2.2.1-2mdk is already installed

what is version  1.2.0 ?  an old version ?

-Walter
GTK 1.2 is the version of GTK Mozilla needs per the Mozilla build instructions,
unless you explicitly enable the (not quite complete) gtk2 code.  Yes, it is an
old version, and gtk2 is not backwards-compatible with it.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

14 years ago
Uninstalling packages gtk+2.0 ..

Uninstallation failed : 
Re:
GTK 1.2 is the version of GTK Mozilla needs per the Mozilla build instructions,
unless you explicitly enable the (not quite complete) gtk2 code.  Yes, it is an
old version, and gtk2 is not backwards-compatible with it.

what is ( not quite complete ) mean ?

If I remove gtk+2.0  I would run into a number of problems:
error: removing these packages would break dependencies:
	gtk+2.0 >= 2.2.1 is needed by libgtk+2.0_0-2.2.1-2mdk
	gtk+2.0 >= 2.1.0 is needed by libbonoboui-2.2.0-1mdk
	gtk+2.0 >= 2.1.5 is needed by gtk-engines2-2.2.0-2mdk
	gtk+2.0 >= 2.2.0 is needed by gnome-terminal-2.2.1-1mdk
	gtk+2.0 >= 2.2.0-3mdk is needed by drakconf-9.1-11mdk
	gtk+2 is needed by perl-GTK2-0.0.cvs.2003.03.04.1-2mdk

> Uninstalling packages gtk+2.0 ..

Why?  Both gtk versions can be installed in parallel; in fact must be for
software linked against gtk 1.x to work while allowing modern software linked
against gtk 2.x to also work.

> what is ( not quite complete ) mean ?

What it says.  Not all the work needed to make Mozilla work with gtk2 has been
done.  Search for bugs with "gtk2" in the summary...

Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.