No way to cancel a click on an <input type=image> image input

RESOLVED DUPLICATE of bug 53966

Status

()

Core
HTML: Form Submission
RESOLVED DUPLICATE of bug 53966
15 years ago
15 years ago

People

(Reporter: Brian 'netdragon' Bober, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
Unlike almost all other navigation images and buttons, when I left click on an
<input type=image>, there is no way to cancel the form submission. EmuMail
employed by RPI uses this element and the behavior is different than with IE

Expected results:
Moving mouse off image before releasing it doesn't send the form submission

Actual results:
There is no way to cancel the click once you do a mousedown

Windows XP and Linux 2003082704
(Reporter)

Comment 1

15 years ago
Created attachment 131454 [details]
Demonstration.

Just press the mouse down and drag, and no matter where you move the mouse, the
form is still submitted.

*** This bug has been marked as a duplicate of 53966 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.