option to check new messages in all IMAP folders

RESOLVED DUPLICATE of bug 91246

Status

--
enhancement
RESOLVED DUPLICATE of bug 91246
15 years ago
14 years ago

People

(Reporter: eric.daspet, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
There is no option in the UI to check new messages in all folders for an IMAP
account.

This is a major issue for people using several mailers/computers as they will
not see messages sorted by other mailers/computers

(thunderbird 0.2)

Comment 1

15 years ago
Yes, I agree that this is a real problem.  I have set up server-side filters to
move mail into various server-side folders, and unless I click on each one, I
won't know about all my new messages.  Of course, this makes reading email much
slower and more cumbersome.

Comment 2

15 years ago
Never mind, I just read Bug #206283.  

Updated

15 years ago
QA Contact: asa

Comment 3

15 years ago
this already exists - there's a hidden pref
(mail.check_all_imap_folders_for_new) - which I don't recommend if you have a
lot of folders, or, on a per folder basis, you can bring up the properties for
the non-inbox folder and check the box that says check this folder for new messages

Comment 4

15 years ago
It's soooo slow doing that. Open dialog, check option, close dialog. Open 
dialog, check option, close dialog. Open dialog, check ... etc. :) There 
really ought to be something akin to the Subscribe dialog where you can choose 
whether or not to check for mail in each folder in one place. 

Comment 5

15 years ago
(In reply to comment #4)
> It's soooo slow doing that. Open dialog, check option, close dialog. Open 
> dialog, check option, close dialog. Open dialog, check ... etc. :) There 
> really ought to be something akin to the Subscribe dialog where you can choose 
> whether or not to check for mail in each folder in one place. 

I want to be able to create new folders for my users on the server so that
messages will have a year-month name.

That wouldn't work for this since the user would have to mark the folder for
checking each month.

Alternatively, I'll just have to move the old messages from the main folder once
they're older than a month...

Comment 6

15 years ago
It would be useful that a folder can be checked with *all* its subfolders:
instead of using the option "check all folders" (which can be long indeed) or to
mark each folder to check, one would filter its message in subfolders of a
specific folder (e.g. diffusion lists), and thunderbird would check
automatically every folder within that one.

Comment 7

15 years ago
That doesn't help me much. I have about 30 folders at the top level under my
account, and I want to check them all (I use server side filtering). Maybe it
would work if you could right click a connection and say "Check Folder for New
Messages" for all folders in the connection.

To be honest, a dialog like the subscription dialog is probably the "right" way
to solve this.

Comment 8

14 years ago
*** Bug 219655 has been marked as a duplicate of this bug. ***

Comment 9

14 years ago
this is a dup of bug 91246

Comment 10

14 years ago
Verified.

*** This bug has been marked as a duplicate of 91246 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.