If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

msn.com - CSS display differences

RESOLVED FIXED

Status

Tech Evangelism Graveyard
English US
--
minor
RESOLVED FIXED
14 years ago
3 years ago

People

(Reporter: Scott Surbrook, Unassigned)

Tracking

({top100})

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

When displayed with IE 5.0 and above, the http://www.msn.com web page displays
the bullets in the "Also on MSN" portion of the page are offset by about 3/16"
from their left margin.  In Firebird, Mozilla, and Netscape 7.1 (I know you are
not responsible for Netscape...), the bullets are either flush with the left
margin (of the column they are in) or are only offset about 1/16".  This causes
the page to display strangely.

Also, in the "Driveaway Vacations" (the picture with test to the right of it,
just to the right of "Also on MSN", Firebird/Mozilla/Netscape display the text
to the right starting at the bottom, rather than the top.  Again, this is not a
fatal flaw, just causes strange behavior.

Since IE now (regretfully) controls about 90-95% of the browser market,
compatibility with it should be important as they are now the defacto
standard... as Netscape was a few years ago.

Thanks for the great product!

Sincerely,

Scott Surbrook

Reproducible: Always

Steps to Reproduce:
1.  Load the msn.com home page.
2.  Look at the "Also on MSN" section and the "MSNBC News" sections.
3.  They are not aligned correctly.
4.  Look at the picture to the right of "Also on MSN".
5.  The text is not aligned/placed correctly.

Actual Results:  
Not sure what else I should explain...

Expected Results:  
Displayed the page like IE 5.0 and later does.  It is the defacto standard.

Comment 1

14 years ago
Mozilla and Firebird render the page the same, so this is not a Firebird bug.

The bullet margins are off because they are applying a -30px margin-left to the
ULs.  This looks OK in IE because IE applies a default 40px left margin to begin
with.  Mozilla applies zero margin and uses padding-left to indent, so in
Mozilla you see a mix of 40px padding-left minus the -30px margin-left.  If they
would just define margin and padding in the CSS, it could work cross-browser
just fine.

And I don't see anything in the code that would require the text to start at the
top of the image in question.  The code has a <span class="floatleft">
suggesting that they wanted the image floating left, but I can't find any float
styling for it in the actual CSS files.

I would consider this a TE bug.
Assignee: blake → english-us
Blocks: 87471
Severity: trivial → minor
Status: UNCONFIRMED → NEW
Component: General → English US
Ever confirmed: true
Keywords: evang500, top100
Product: Firebird → Tech Evangelism
QA Contact: asa → english-us
Summary: msn.com does not display correctly. → msn.com - CSS display differences

Comment 2

14 years ago
they look comparable in yesterdays mozilla 1.7 on winxp and msie6
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.