bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Moz hangs on various activities when started for the first time after booting the PC

RESOLVED WORKSFORME

Status

SeaMonkey
General
--
critical
RESOLVED WORKSFORME
15 years ago
14 years ago

People

(Reporter: Nina Cording, Unassigned)

Tracking

({hang})

Trunk
x86
Windows 98

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.5b) Gecko/20030908
Build Identifier: Mozilla/5.0 (Windows; U; Win 9x 4.90; en-US; rv:1.5b) Gecko/20030908

Mozilla hangs on various activities when started for  the first time after
booting the PC, that include:

1 - dragging a file into the Message composer
2 - attaching a file to an email and using the topmost drop-box for folders or
one of the big buttons on the left labeled "Desktop", etc...
3 - downloading a file and using the same controls as described in nr.2
4 - saving a file and using the same controls as described in nr.2

So if I do anything listed above, Mozilla hangs up. I have to kick it out from
the taskmanager.

Now to the Twilight-Zone(tm) Part:
If I start Mozilla for the 2nd time after booting (Sorry, I don't know if this
works if you don't use the taskmanager to quit the first Moz. session),
those actions listed above work fine.

So now I use to press ctrl-s after every sentence I type in the mails I write,
because I very often forget about that bug, so there'll be not so much lost if
the bug occurs again.

I couldn't notice a similar behaviour in any other application.
It's ONLY and just only Mozilla that behaves this way on my system.

Reproducible: Always

Steps to Reproduce:
1. Boot the system
2. Start Mozilla
3. Do one of the actions above (dragging file into message composer, downloading
file using special controls in  the upload/download file dialog)

Actual Results:  
Mozilla hangs, needs to be closed with taskmanager

Expected Results:  
NOT hang. Just continue.

...occurs independent of installed theme
...using windows ME (>400MB ram, 1GHZ Athlon, etc...)
...no crash or error message, Mozilla just hangs.
Maybe there's some way to find out what happened before mozilla hangs, a
log-file that's deleted after closing the app, or something similar to the way
that windows detects an "unclean" reboot?
I'm a bit new to debugging, but it would be great to have an option like "start
logging" and "stop logging" that writes permanently into a log-file so you can
analyze it afterwards. maybe  there is already such a function and I didn't know
it until now.

Updated

15 years ago
Keywords: hang
Product: Browser → Seamonkey
wfm
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.