Sidebar Customise dialog needs to use dialogOverlay for confirm buttons

VERIFIED FIXED in M15

Status

SeaMonkey
Sidebar
P3
normal
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Henrik Gemal, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
If you press customize.. in the side you see a new window where the Cancel and
Save buttons in the in wrong order.
The buttons should be like this:
Save - Cancel
and not
Cancel - Save

You always have the Ok button before the Cancel button!

Updated

18 years ago
Assignee: slamm → german

Comment 1

18 years ago
Reassigning to german.
German, which way would you like to do it.
I could not find it in the spec.
(Reporter)

Comment 2

18 years ago
Could someone please check this in.
Diff output to correct this bug:

168a169,172
>     <titledbutton onclick="window.close()"
>        class="dialog push"
>        value="&sidebar.customize.cancel.label;" />
>     <spring flex="4%"/>
173,176d176
<     <spring flex="4%"/>
<     <titledbutton onclick="window.close()"
<        class="dialog push"
<        value="&sidebar.customize.cancel.label;" />
(Reporter)

Comment 3

18 years ago
Any chance for this BIG bug being fixed....!
It's a simple copy-paste source code change

Comment 4

18 years ago
cc:ing ben@netscape.com, making he can check it in
need to use dialogOverlay to get appropriate ordering on each platform. should 
be a simple fix... 
Assignee: german → ben
Summary: Cancel & Save buttons is not in the correct order → Sidebar Customise dialog needs to use dialogOverlay for confirm buttons
Status: NEW → ASSIGNED
Target Milestone: M15
holding fix in tree for M15 open

Comment 7

18 years ago
*** Bug 30040 has been marked as a duplicate of this bug. ***
done and done
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 9

18 years ago
qa to shrir
QA Contact: paulmac → shrir

Comment 10

18 years ago
verif fixed on all builds (2000041706)
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.