Crash with Shockwave (latest version) when rapidly clicking

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
15 years ago
2 years ago

People

(Reporter: captainktainer, Assigned: peterlubczynski-bugs)

Tracking

({crash})

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827

Mozilla crashes out entirely when rapidly clicking within this particular
shockwave interface- I don't dare test it on other sites.

Reproducible: Always

Steps to Reproduce:
1. Load URL
2. Save any work that might possibly be important to you (you may skip this step)
3. Poke the bunny rapidly

Actual Results:  
Mozilla crashes, sends info to Microsoft and Talkbalk Agent.

Expected Results:  
Continued poking the bunny rapidly until it bites your finger

Modern theme. In the interests of full disclosure, I should mention that my
system/preformatted font has become corrupted to another, decorative font, for
some reason only in Mozilla. The shockwave behavior only began to occur after
upgrading to 1.5 beta from 1.4 final. Also, I classified the bug as critical
because it *is* a crash bug, and could affect some sites involving Shockwave
games- though in practicality it's more of an unfortunate and annoying nuisance
for me.

Comment 1

15 years ago
Aaron: Could you provide TalkBack incident ID? Run
"mozilla.org/bin/components/talkback.exe" and post the talkback ID of that crash
in this bug.
Keywords: crash
(Reporter)

Comment 2

15 years ago
I have two Talkback IDs:
TB23630042H
TB23630021W

FYI, the location of my talkback is in mozilla.org\Mozilla\components. Took me
some searching to find it.
Incident ID:    
Incident ID 23630042
Stack Signature 	0x00000000 37f6eef7
Email Address 	
Product ID 	MozillaTrunk
Build ID 	2003082704
Trigger Time 	2003-09-15 20:39:41
Platform 	Win32
Operating System 	Windows NT 5.1 build 2600
Module 	
URL visited 	
User Comments 	
Trigger Reason 	Access violation
Source File Name 	
Trigger Line No. 	
Stack Trace 	
0x00000000
DirectSound.x32 + 0x24d8 (0x6e1424d8)
DirectSound.x32 + 0x1938 (0x6e141938)
IML32.dll + 0x21508 (0x69021508)
DIRAPI.dll + 0x24bad (0x68024bad)
DIRAPI.dll + 0x2551a (0x6802551a)
DIRAPI.dll + 0x623a8 (0x680623a8)
DIRAPI.dll + 0x615c0 (0x680615c0)
DIRAPI.dll + 0x6128b (0x6806128b)
DIRAPI.dll + 0x62309 (0x68062309)
DIRAPI.dll + 0x2f7c2 (0x6802f7c2)
DIRAPI.dll + 0x123e5 (0x680123e5)
DIRAPI.dll + 0xc8ec (0x6800c8ec)
DIRAPI.dll + 0xc764 (0x6800c764)
DIRAPI.dll + 0xc8e2d (0x680c8e2d)
DIRAPI.dll + 0xd74e4 (0x680d74e4)
DIRAPI.dll + 0xbb982 (0x680bb982)



Incident ID:    
Incident ID 23630021
Stack Signature 	0x0000066c 339680b5
Email Address 	
Product ID 	MozillaTrunk
Build ID 	2003082704
Trigger Time 	2003-09-15 20:38:05
Platform 	Win32
Operating System 	Windows NT 5.1 build 2600
Module 	
URL visited 	
User Comments 	
Trigger Reason 	Access violation
Source File Name 	
Trigger Line No. 	
Stack Trace 	
0x0000066c
DirectSound.x32 + 0x1aa6 (0x6e141aa6)
DirectSound.x32 + 0x18ce (0x6e1418ce)
IML32.dll + 0x21508 (0x69021508)
DIRAPI.dll + 0x24bad (0x68024bad)
DIRAPI.dll + 0x2551a (0x6802551a)
DIRAPI.dll + 0x623a8 (0x680623a8)
DIRAPI.dll + 0x615c0 (0x680615c0)
DIRAPI.dll + 0x6128b (0x6806128b)
DIRAPI.dll + 0x62309 (0x68062309)
DIRAPI.dll + 0x2f7c2 (0x6802f7c2)
DIRAPI.dll + 0x123e5 (0x680123e5)
DIRAPI.dll + 0xc8ec (0x6800c8ec)
DIRAPI.dll + 0xc764 (0x6800c764)
DIRAPI.dll + 0xc8e2d (0x680c8e2d)
DIRAPI.dll + 0xd74e4 (0x680d74e4)
DIRAPI.dll + 0xbb982 (0x680bb982)

Comment 4

15 years ago
I could reproduce this with Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US;
rv:1.7b) Gecko/20040316. Not sure about the flash and director versions, though.
Flash was 6ish. Talkback ID: TB8581G

Upgraded to latest flash (7.0 rc19) and director (10.0), couldn't reproduce. So
upgrading flash seems to fix it.

Updated

15 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WORKSFORME

Updated

9 years ago
Component: Plug-ins → Shockwave (Adobe)
Product: Core → Plugins
QA Contact: bmartin → adobe-shockwave
Version: Trunk → unspecified
Product: Plugins → Plugins Graveyard
You need to log in before you can comment on or make changes to this bug.