Hide Root Bookmark in bookmark manager

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
--
trivial
RESOLVED WORKSFORME
15 years ago
12 years ago

People

(Reporter: Ryuichi KUBUKI, Assigned: Pierre Chanial)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030914 Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030914 Firebird/0.6.1+

"Bookmarks" root folder in Bookmarks manager is redundant. Right-click context
menu on it have nothing other than collapse and you can't add any other objects
beside it. Moreover it will hinder i17n since the name "Bookmarks" is English.
Bookmarks Sidebar doesn't have it, so hiding it  in BM will increase consistency.

Reproducible: Always

Steps to Reproduce:
agreed.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: "Bookmarks" root folder in Bookmarks manager is redundant → Hide Root Bookmark

Comment 2

15 years ago
The root folder has to appear in the add-bookmark dialog, so the i17n argument
is wrong.
Summary: Hide Root Bookmark → Hide Root Bookmark in bookmark manager
(Reporter)

Comment 3

15 years ago
Comment #2:
Then why is it missing from sidebar?
If add-bookmark dialog needs root add it only to add-bookmark dialog, not to
Bookmarks Manager. Nevertheless i17n is trivial here, I agree.
this would also partially resolve bug 214966 (unable to import bookmarks unless
a folder or bookmark is selected)

Comment 5

14 years ago
Created attachment 152252 [details] [diff] [review]
Patch V1

Change change ref to be bookmark root instead of top root.
(Reporter)

Updated

14 years ago
Depends on: 248577
(Reporter)

Comment 6

14 years ago
(In reply to comment #5)
> Created an attachment (id=152252)
> Patch V1
> 
> Change change ref to be bookmark root instead of top root.

Is this patch alright with bug 248577?
(Reporter)

Comment 7

14 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8a3) Gecko/20040729
Firefox/0.9.1+

Now with the lefthand pane of Bookmark Manager, you can hide the root folder in
the right pane by selecting the root folder in the left. In other words, the
root folder in the left can't be removed because if it's removed you can't see
all bookmarks in one pane in the right.

Comment 8

14 years ago
You're in the Bookmarks dialog, so everyone knows you're working on bookmarks.  
Having a root of "bookmarks" is pointless, and clicking on it creates a 
redundant treeview in the right pane.  Two bafflingly redundant treeviews is 
currently the default condition, and that's bad.

No offense, but I am mystified by this:
"In other words, the root folder in the left can't be removed because if it's 
removed you can't see all bookmarks in one pane in the right."

Why would you want to?  You can see them on the left!
(Reporter)

Comment 9

14 years ago
(In reply to comment #8)
> No offense, but I am mystified by this:
> "In other words, the root folder in the left can't be removed because if it's 
> removed you can't see all bookmarks in one pane in the right."
> 
> Why would you want to?  You can see them on the left!

I always hide the left pane (See Bug 247742, though you can now hide it
effectively by dragging the separator bar to the left frame - I use it in the
old Netscape style without the left pane, or in the IE Favorites style) as I
don't need it. I hate this fat interface with the left pane which is absent in
Bookmarks Sidebar ;) Someone may find it useful, but I definitely hate it and
the left pane is against the Firefox policy that it imitates IE's interface to
stand as an possible alternative (at least I was told so at Bug 262103 Comment #1).
(Reporter)

Comment 10

14 years ago
depends on 247742 - but devs feel free to mark this bug FIXED & VERIFIED as I
have no problem on this particular bug now as I suggested in comment 7!
Depends on: 247742

Comment 11

14 years ago
KL makes a good argument.  The dual-pane view seems pointless and should be 
done away with.  Is there a bug out there suggesting that?

Meanwhile, I'll do just as he suggests and hide the left pane.  I rescind my 
vote for this bug.
(Reporter)

Updated

14 years ago
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WORKSFORME
sorry for bugspam, long-overdue mass reassign of ancient QA contact bugs, filter on "beltznerLovesGoats" to get rid of this mass change
QA Contact: mconnor → bookmarks
You need to log in before you can comment on or make changes to this bug.