no autocomplete in other windows with xbl generated alert button

RESOLVED WORKSFORME

Status

()

Core
XBL
--
minor
RESOLVED WORKSFORME
15 years ago
11 years ago

People

(Reporter: Martijn Wargers (zombie), Unassigned)

Tracking

({testcase})

Trunk
x86
All
testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

955 bytes, application/xhtml+xml
Details
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030911 Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030911 Firebird/0.6.1+

See
http://home.hccnet.nl/m.wargers/test/mozilla/firebird/autocomp.htm
http://home.hccnet.nl/m.wargers/test/mozilla/firebird/

The first button is generated with xbl, the seconde one in the normal way.
Although the two activate the same function, the first one causes autocomplete
to stop working on other firebird windows.

Reproducible: Always

Steps to Reproduce:
1. Open two firebird windows
2. Open in one the above url:
http://home.hccnet.nl/m.wargers/test/mozilla/firebird/autocomp.htm
3. Click on the topmost button
4. Try to activate autocomplete in the other firebird window.

Actual Results:  
No autocomplete. And javascript errors in the javascript console:
Error: [Exception... "'Permission denied to get property XULElement.searchParam'
when calling method: [nsIAutoCompleteInput::searchParam]"  nsresult: "0x8057001e
(NS_ERROR_XPC_JS_THREW_STRING)"  location: "JS frame ::
http://home.hccnet.nl/m.wargers/test/mozilla/firebird/autocomp.xml :: anonymous
:: line 13"  data: no]
Source File: http://home.hccnet.nl/m.wargers/test/mozilla/firebird/autocomp.xml
Line: 13

Expected Results:  
Show the autocomplete.

This happens also for a prompt dialog, and most likely also for a confirm dialog.

Comment 1

15 years ago
WFM winXP Gecko/20030913 Firebird/0.6.1+

Comment 2

15 years ago
I finally see what this bug is about. You can't dismiss the dialog. In the first
case, autocomplete fails to work in other windows when the dialog is up. But in
the second case leaving the dialog up has no effect on autocomplete in other
windows.

I consider this a minor bug though since the chances of coming across something
like it is slim. It's more of a quirk than a bug.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Martijn, do you still have the testcase (currently 404)? Is this bug still present?
Assignee: hewitt → nobody
QA Contact: davidpjames → location.bar
(Reporter)

Comment 4

13 years ago
Created attachment 198737 [details]
Testcase

Yes, here is the testcase, it still gives the same error.
(Reporter)

Comment 5

13 years ago
More an xbl issue, I guess.
Assignee: nobody → general
Component: Location Bar and Autocomplete → XBL
Keywords: testcase
Product: Firefox → Core
QA Contact: location.bar → ian
Version: unspecified → Trunk
We seem to be running into trouble because we call IsFocusable in nsXULElement,
which calls into chrome JS, but there is content JS on the stack, so we think
we're trying to call chrome JS from content JS and throw a security exception...

I doubt this is really an XBL issue.
(Reporter)

Comment 7

11 years ago
This seems to be worksforme, using current trunk and FF2009.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.