All users were logged out of Bugzilla on October 13th, 2018

[DOGFOOD][REGRESSION] Mail folder pane is empty

VERIFIED FIXED

Status

P1
blocker
VERIFIED FIXED
19 years ago
14 years ago

People

(Reporter: huang, Assigned: sspitzer)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+])

(Reporter)

Description

19 years ago
After go to tasks menu -> mail.

The mail is totally blank there for both IMAP & POP accounts.

Updated

19 years ago
Severity: critical → blocker
Priority: P3 → P1

Comment 1

19 years ago
Build ID: 1999121608

To reproduce:
- Launch mozilla
- Select Tasks | Mail

Result: The contents of the Mail Folders panel is blank.

Updated

19 years ago
Assignee: phil → alecf
Summary: [DOGFOOD]Blank mail accounts for both POP & IMAP accounts → [DOGFOOD] Mail folder pane is empty

Comment 2

19 years ago
The sidebar in the browser looks ok on Karen's machine, but in the mail sidebar,
there are no accounts/folders and no sidebar panels.

Reassign to alecf, cc putterman
(Reporter)

Comment 3

19 years ago
Provide IMAP account Console information as following:

./mozilla -installer
.//run-mozilla.sh ./mozilla-bin -installer
MOZILLA_FIVE_HOME=/home/khuang/seamonkey/package
  LD_LIBRARY_PATH=/home/khuang/seamonkey/package:/home/khuang/seamonkey/package/
Cool
      XPCS_HOME=/home/khuang/seamonkey/package/Cool
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
nNCL: registering deferred (0)
WEBSHELL+ = 1
WEBSHELL+ = 2
nsXULKeyListenerImpl::Init()
-----  Migrating prefs
-----  Migrating prefs done null
TODO:  port / fix / turn on the code that checks for space before copying.
WEBSHELL- = 1
WEBSHELL- = 0
WEBSHELL+ = 1
 I am inside the initialize
 Hey : You are in QFA Startup
(QFA)Talkback loaded Ok.
WEBSHELL+ = 2
nsXULKeyListenerImpl::Init()
nsCollationUnix::Initialize mLocale = C
/home/khuang/seamonkey/package/Cool/Xpcs Registry.dat: invalid ELF headerWEBSHEL
L+ = 3
Setting content window
browser.startup.page = 1
startpage = http://www.mozilla.org/
in SetSecurityButton
! nsSecureBrowserUIImpl found: chrome://navigator/content/
change lock icon to unlock ?(chrome 0)
WEBSHELL+ = 4
change lock icon to unlock - new document
Document http://www.mozilla.org/ loaded successfully
Document: Done (2.886 secs)
! nsSecureBrowserUIImpl found: http://www.mozilla.org/
change lock icon to unlock ?(http 0)
! nsSecureBrowserUIImpl found: chrome://related/content/related-panel.xul
change lock icon to unlock ?(chrome 0)
we don't handle eBorderStyle_close yet... please fix me
WEBSHELL+ = 5
change lock icon to unlock - new document
nsXULKeyListenerImpl::Init()
WEBSHELL+ = 6
change lock icon to unlock - new document
! nsSecureBrowserUIImpl found: about:blank
change lock icon to unlock ?(about 0)

OnUnload from XUL
Clean up ...
attempt to UpgradePrefs.  If that fails, open the account wizard.
There are 0 smtp servers
before clearItemSelection
change lock icon to unlock - new document
start message pane with: http://www.mozilla.org/mailnews/start.html
in showthreads
In onLoadfolderPane
In sortColumn
Sort failed: [Exception... "Component returned failure code: 0x80004005 (NS_ERRO
R_FAILURE) [nsIXULSortService.Sort]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"
location: "JS frame :: chrome://messenger/content/commandglue.js :: SortColumn
:: line 314"  data: no]
SetupCommandUpdateHandlers
WEBSHELL+ = 7
! nsSecureBrowserUIImpl found: chrome://messenger/content/
change lock icon to unlock ?(chrome 804b0002)
! nsSecureBrowserUIImpl found: about:blank
change lock icon to unlock ?(about 804b0002)
WEBSHELL- = 6
WEBSHELL- = 5
WEBSHELL- = 4
we don't handle eBorderStyle_close yet... please fix me
WEBSHELL+ = 5
JavaScript Error: ReferenceError: OnUnloadMessenger is not defined

change lock icon to unlock - new document
nsXULKeyListenerImpl::Init()
WEBSHELL+ = 6
change lock icon to unlock - new document
! nsSecureBrowserUIImpl found: about:blank
change lock icon to unlock ?(about 0)

OnUnload from XUL
Clean up ...
change lock icon to unlock - new document
start message pane with: http://www.mozilla.org/mailnews/start.html
in showthreads
In onLoadfolderPane
In sortColumn
Sort failed: [Exception... "Component returned failure code: 0x80004005 (NS_ERRO
R_FAILURE) [nsIXULSortService.Sort]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"
location: "JS frame :: chrome://messenger/content/commandglue.js :: SortColumn::
line 314"  data: no]
SetupCommandUpdateHandlers
WEBSHELL+ = 7
! nsSecureBrowserUIImpl found: chrome://messenger/content/
change lock icon to unlock ?(chrome 804b0002)
! nsSecureBrowserUIImpl found: about:blank
change lock icon to unlock ?(about 804b0002)
WEBSHELL- = 6
WEBSHELL- = 5
WEBSHELL- = 4
WEBSHELL- = 3
WEBSHELL- = 2
Hey : You are in QFA Shutdown
WEBSHELL- = 1
[khuang@h-208-12-40-169 package]$
[khuang@h-208-12-40-169 package]$ ./mozilla
.//run-mozilla.sh ./mozilla-bin
MOZILLA_FIVE_HOME=/home/khuang/seamonkey/package
  LD_LIBRARY_PATH=/home/khuang/seamonkey/package:/home/khuang/seamonkey/package/
Cool
      XPCS_HOME=/home/khuang/seamonkey/package/Cool
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
     moz_debugger=
nNCL: registering deferred (0)
WEBSHELL+ = 1
nsXULKeyListenerImpl::Init()
start with profile: msg41_3qt06pop
WEBSHELL- = 0
WEBSHELL+ = 1
 I am inside the initialize
 Hey : You are in QFA Startup
(QFA)Talkback loaded Ok.
WEBSHELL+ = 2
nsXULKeyListenerImpl::Init()
nsCollationUnix::Initialize mLocale = C
/home/khuang/seamonkey/package/Cool/Xpcs Registry.dat: invalid ELF headerW
L+ = 3
Setting content window
browser.startup.page = 1
startpage = http://www.mozilla.org/
in SetSecurityButton
failed to set the page title.
! nsSecureBrowserUIImpl found: chrome://navigator/content/
change lock icon to unlock ?(chrome 0)
WEBSHELL+ = 4
change lock icon to unlock - new document
Document http://www.mozilla.org/ loaded successfully
Document: Done (2.304 secs)
! nsSecureBrowserUIImpl found: http://www.mozilla.org/
change lock icon to unlock ?(http 0)
! nsSecureBrowserUIImpl found: chrome://related/content/related-panel.xul
we don't handle eBorderStyle_close yet... please fix me
WEBSHELL+ = 5
change lock icon to unlock - new document
nsXULKeyListenerImpl::Init()
WEBSHELL+ = 6
change lock icon to unlock - new document
! nsSecureBrowserUIImpl found: about:blank
change lock icon to unlock ?(about 0)

OnUnload from XUL
Clean up ...
change lock icon to unlock - new document
start message pane with: http://www.mozilla.org/mailnews/start.html
in showthreads
In onLoadfolderPane
In sortColumn
Sort failed: [Exception... "Component returned failure code: 0x80004005 (NS_ERRO
R_FAILURE) [nsIXULSortService.Sort]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"
location: "JS frame :: chrome://messenger/content/commandglue.js :: SortColumn
:: line 314"  data: no]
SetupCommandUpdateHandlers
WEBSHELL+ = 7
! nsSecureBrowserUIImpl found: chrome://messenger/content/
change lock icon to unlock ?(chrome 804b0002)
! nsSecureBrowserUIImpl found: about:blank
change lock icon to unlock ?(about 804b0002)
WEBSHELL- = 6
WEBSHELL- = 5
WEBSHELL- = 4
WEBSHELL- = 3
WEBSHELL- = 2
Hey : You are in QFA Shutdown
WEBSHELL- = 1
[khuang@h-208-12-40-169 package]$ setenv PROFILE_NAME msg41_qt30
[khuang@h-208-12-40-169 package]$ setenv PROFILE_HOME /home/khuang/msg41_qt30
[khuang@h-208-12-40-169 package]$ ./mozilla -installer
.//run-mozilla.sh ./mozilla-bin -installer
MOZILLA_FIVE_HOME=/home/khuang/seamonkey/package
  LD_LIBRARY_PATH=/home/khuang/seamonkey/package:/home/khuang/seamonkey/package/
Cool
      XPCS_HOME=/home/khuang/seamonkey/package/Cool
      MOZ_PROGRAM=./mozilla-bin
      MOZ_TOOLKIT=
        moz_debug=0
                                                                              
WEBSHELL+ = 2
nsXULKeyListenerImpl::Init()
nsCollationUnix::Initialize mLocale = C
/home/khuang/seamonkey/package/Cool/Xpcs Registry.dat: invalid ELF
headerWEBSHELL+ = 3
Setting content window
browser.startup.page = 1
startpage = http://www.mozilla.org/
in SetSecurityButton
! nsSecureBrowserUIImpl found: chrome://navigator/content/
change lock icon to unlock ?(chrome 0)
WEBSHELL+ = 4
change lock icon to unlock - new document
Document http://www.mozilla.org/ loaded successfully
Document: Done (2.196 secs)
! nsSecureBrowserUIImpl found: http://www.mozilla.org/
change lock icon to unlock ?(http 0)
! nsSecureBrowserUIImpl found: chrome://related/content/related-panel.xul
change lock icon to unlock ?(chrome 0)
we don't handle eBorderStyle_close yet... please fix me
WEBSHELL+ = 5
change lock icon to unlock - new document
nsXULKeyListenerImpl::Init()
WEBSHELL+ = 6
change lock icon to unlock - new document
! nsSecureBrowserUIImpl found: about:blank
change lock icon to unlock ?(about 0)

The POP account is the same result.

Comment 4

19 years ago
fyi,
I see this problem too on today linux commercial seamonkey build
1999-12-16-08-12 using a migrated profile or creating a new profile.  I looked
in my prefs.js file.  As far as I can tell, all the correct information is
present.

Symptoms: Sidebar in the browser is present.  The mail sidebar is missing.
early bird gets the worm.  I'm looking at this now.

Updated

19 years ago
Summary: [DOGFOOD] Mail folder pane is empty → [DOGFOOD][REGRESSION] Mail folder pane is empty

Updated

19 years ago
OS: Linux → All
Hardware: PC → All

Comment 6

19 years ago
I see this in the 1999121608 build under NT as well.
(Reporter)

Comment 7

19 years ago
Yes. Same result for WinNT 12-16-09-M12 for both IMAP & POP accounts

Comment 8

19 years ago
I actually *don't* see this on windows NT.

Comment 9

19 years ago
I very much see this on WinNT but here's the good stuff:

this bug was introduced during the Windows respin yesterday, it appears for the first time in the
1999121516 build for Win32. Given that, I bet someone could narrow it down to the offending
checkin fairly easily.
(Reporter)

Comment 10

19 years ago
Yes. I went back to the previous Linux 12-15-16-M12 commercial build:
Problem already existed for yesterday afternoon's commercial build.

Comment 11

19 years ago
fyi,
I can not reproduce this problem in today Mac commercial seamonkey build
1999-12-16-09-m12.  I ran the mac installer program and was able to successfully
migrate a IMAP profile.  I was able to see my folder and access my mail.

/Peter

Updated

19 years ago
Assignee: alecf → sspitzer

Comment 12

19 years ago
sounds like seth fixed the problem, reassigning to him and marking fixed

Updated

19 years ago
Whiteboard: [PDT+]

Comment 13

19 years ago
PDT+

Comment 14

19 years ago
Seems fixed to me in the 1999121612 build under Linux.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED
marking fixed.
(Reporter)

Comment 16

19 years ago
Verified on Linux 12-16-12-M12 commercial for both IMAP & POP accounts.
Works OK for this build now...will check WinNT later....
(Reporter)

Updated

19 years ago
QA Contact: lchiang → huang
(Reporter)

Comment 17

19 years ago
Change QA contact to me. Cc: Lisa.
(Reporter)

Updated

19 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 18

19 years ago
Verified on WinNT on 12-16-12-M12 commercial builds - Works OK now.
Since Peter Mock reported this bug not happened for the Mac platform.
So, I am marking as verified now.
I will still verify on the Mac for the 12-16-12-M12 build later....
But my Mac is very slow.....will keep you updating that!! Mark as Verified!!

Comment 19

19 years ago
Thanks for the fast turnaround on this bug.

Comment 20

19 years ago
*** Bug 21955 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 21

19 years ago
I still verified on Mac 12-16-12-M12 build.
It works OK for the fix of this bug. But Mac crashed many time whenever I start
or exit. "Not stable enough!!" I believe that we already have bug for that!!
But, I don't know the bug number!! Anyway,...Leave this bug as "verified"!!
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.