Closed Bug 21942 Opened 20 years ago Closed 20 years ago

[Win98] menus show up on primary monitor in a multiple monitor environment

Categories

(Core :: XUL, defect, P4)

x86
Windows 98
defect

Tracking

()

VERIFIED FIXED

People

(Reporter: sdm, Assigned: mikepinkerton)

References

Details

Menus popups, such as the context menu and the menubar at the top of the
browser, display on the primary monitor, even if the browser is being displayed
in another monitor, on win98.

I'm not a windows developer, but there's a lot of info here:
http://msdn.microsoft.com/library/psdk/gdi/monitor_53sj.htm
as to what needs to be done to play nice with multiple monitors on windows.
I believe it involves getting the current monitor before showing the object.
Assignee: trudelle → saari
Priority: P3 → P4
Target Milestone: M16
assigning to saari as p4 for m16, cc hyatt since he's using Win98 too.
Hey, smorrison, do combo boxes (selects) do this too?
combo boxes show up on the correct monitor, in the correct position. The editor
color selector does not. The 'customize sidebar' and editor toolbar dialogs pop
up in the right place.
Assignee: saari → hyatt
Summary: menus show up on primary monitor in a multiple monitor environment → [Win98] menus show up on primary monitor in a multiple monitor environment
Status: NEW → ASSIGNED
I wonder why combo boxes would work but the XUL popups would not.  cc'ing rods
and kmcclusk to find out if they resolved this issue for combo boxes already,
and if they know what I need to do in my own code to also resolve the issue.
*** Bug 27575 has been marked as a duplicate of this bug. ***
*** Bug 19347 has been marked as a duplicate of this bug. ***
*** Bug 29876 has been marked as a duplicate of this bug. ***
*** Bug 30425 has been marked as a duplicate of this bug. ***
*** Bug 30804 has been marked as a duplicate of this bug. ***
This problem is nsDeviceContextWin::CommonInit(HDC aDC) in 
mozilla/gfx/src/windows/nsDeviceContextWin.cpp.
*** Bug 25747 has been marked as a duplicate of this bug. ***
*IGNORE* - massive spam changing open XPToolkit bug's QA contact to
jrgm@netscape.com
QA Contact: paulmac → jrgm
reassigning to pink
Assignee: hyatt → pinkerton
Status: ASSIGNED → NEW
accepting for m15, close to a fix for xul popups on win32
Status: NEW → ASSIGNED
Depends on: 32611
Target Milestone: M16 → M15
done and done. works on hyatt's win2k box.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
verified
Status: RESOLVED → VERIFIED
*** Bug 34493 has been marked as a duplicate of this bug. ***
*** Bug 34468 has been marked as a duplicate of this bug. ***
*** Bug 34223 has been marked as a duplicate of this bug. ***
As posted in the latest comments for bug 36479, this bug seems to be recurring. 
See my comments in bug 36479 for details, and if this is the same bug. My big 
post towards the bottom has this bug's symptoms.
*** Bug 34223 has been marked as a duplicate of this bug. ***
Do the following:

1. Startup W2K with one monitor active
2. Startup Mozilla (Build 2000080620)
3. Activate the second monitor under W2K and extend the desktop to it
4. Move the Mozilla window to the second (new) monitor
5. All menus now draw on the right side of the primary monitor

It seems that enabling a second monitor AFTER Mozilla startup is not recognized
by Mozilla.

Just a nice to have fixed thing...

André.
I am still seeing this bug on build 2002061308. I can reproduce using the steps
in comment #22.
This happens on Mac (Powerbook G4/800 DVI running OS X 10.1.5).

Please change to all platform/OS.

Thanks.

Max.
*** Bug 133858 has been marked as a duplicate of this bug. ***
WinXP or Win2000

Mozilla/5.0 rv:1.1 Gecko/20020826

Same problem but with dependent windows (view source, etc.).  I dupped bug 133858.  

Reporter sdm@pobox.com can you reopen this?
bug 98830 is the new instance of this one
Please re-open this bug (21942). Further problem still remains.

Symptom: Menu displayed in the wrong monitor if a larger percentage of the
browser are resides in the other monitor.

Build: MOZ 1.3 stable; Windows XP Professional

Steps for reproducing:

1. Have two monitors, secondary set on the left side of primary. (For my setup,
the primary is 1600x1200, and secondary 1024x768 on the left bottom of my
primary monitor)
2. Open a Mozilla window (browser or mail/news does not matter), resize it
horizontally so that the window width is just enough so all of the menu names
(from File to Help) shows.
3. Drag the said window to the middle of the two monitors, so the left part of
the window displays on the secondary (left) monitor, and the right part on the
primary. For now, please ensure that the left "portion" has a larger area than
the right.
4. click on a menu, like "file." The actual menu should display properly.
5. click on "Help," which should be right no in the primary (right) monitor -
the menu would display on the primary monitor, which is an incorrect behavior.
6. now resize (horizontally) the right side of the window until the right side
portion is larger than the left.
7. repeat step 4 and 5 and the result has reversed - the help menu displays
properly, but the file menu does not.

Additional information:
The computer I use is a laptop (Fujitsu) with an Intel graphics chipset (AGP
only - does not have dedicated graphics memory). Furthermore, the way to get
dual monitor functionality from this computer may be different from other
desktop variants. From the behavior I do not believe it is a hardware or driver
dependent problem - but the information is here if it proves to be helpful.
You need to log in before you can comment on or make changes to this bug.