Popup blocking blocks popup from link

RESOLVED DUPLICATE of bug 206591

Status

SeaMonkey
General
RESOLVED DUPLICATE of bug 206591
14 years ago
4 years ago

People

(Reporter: Jørgen Nørgaard, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030916
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030916

Mozilla blocks popup windows that are a result of interaction, for example
clicking a link.

This seems to have been introduced recently.

Does not happen with FireBird 0.6.1+, but also in recent nightlies of FireBird.

Reproducible: Always

Steps to Reproduce:
1.On the URL, find the link "vid Turning Torso"
2. click the link, does not open a window and show the icon for 'blocked window'
3.
This seems to work correctly with a 1.5b build on Windows... Could you possibly
narrow down the exact date range when this broke?
Oddly enough, clicking on that link works fine for me using build 2003-09-17-04
on Windows 2000.

http://w1.sydsvenskan.se//Article.jsp?article=10028664
(Reporter)

Comment 3

14 years ago
Strange, works for me also, using the same build as yesterday.


(Reporter)

Comment 4

14 years ago
I wonder if the problem may be something entirely different.

While a page is still loading requested popups are blocked. As soon as the load
is complete, the requested popups work as expected


Example:
http://anneli.dk/~jnp/test/HTML/popup/b.html

Locate the piece about Isabel, under the heading "Grafik:" are a couple of links
that popup windows.

While loading is not complete this links' popup window does not show.

(Is this somewhat comprehensible??)
> While a page is still loading requested popups are blocked.

Yep.  Popup blocking blocks all calls to window.open() that happen before the
onload event.  There is an existing bug on that.
Whiteboard: DUPEME

Comment 6

14 years ago

*** This bug has been marked as a duplicate of 206591 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Updated

4 years ago
Whiteboard: DUPEME
You need to log in before you can comment on or make changes to this bug.