Step-by-step Install perl optional module version inconsistent

RESOLVED WONTFIX

Status

()

Bugzilla
Installation & Upgrading
RESOLVED WONTFIX
15 years ago
5 years ago

People

(Reporter: Gary Beckmann, Assigned: zach)

Tracking

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

In the 2.16.3 guide section 4.1.2. Package list, under the optional modules the
text reads
  GD (v1.19) for bug charting
  Chart::Base (v0.99c) for bug charting
However, on CPAN the Chart::Base version 0.99-pre3 (there is no 0.99) reguires
GD 1.20 or greater. 

Note that the version for GD has been updated to 1.20 in the development branch
  (2.17.4) guide.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

15 years ago
The version listed here matches what's in checksetup.pl for 2.16.
Assignee: jake → zach
Component: Documentation → Installation & Upgrading
Version: unspecified → 2.16.3

Comment 2

14 years ago
This seems so simple, yet nothing's ever been done about it... though I guess it
does require changing checksetup.pl to maintain the integrity... or is it OK if
the two are different?
Status: UNCONFIRMED → NEW
Ever confirmed: true
Chart::Base never reported the a/b/c or pre3 on the version number, all it
reported was 0.99.  This is why checksetup.pl only checks for that.  0.99b works
with GD 1.19.  0.99c did, too, I believe.  It's quite conceivable that someone
has it installed on a machine with 0.99b...  I don't think we should bump the
tests in checksetup.pl because it would then suddenly break someone that
upgrades the 'stable' version.  That's one of the golden rules for the stable
branches is don't alter the dependencies without a damn good reason (like to fix
a security bug).
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.