cgmeditrans.com - image reported as text/html

RESOLVED FIXED

Status

--
trivial
RESOLVED FIXED
16 years ago
4 years ago

People

(Reporter: rr_mozilla, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

16 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030827

These two sites display a page full of junk characters e.g.
"(ª÷÷Öúf�sy'—kkÍ3í'j(%Ž'". No html is rendered. Sites work on IE.
"View/Page Source" is similarly corrupted.

Reproducible: Always

Steps to Reproduce:
1. Type in URL
2. View corrupted results
3. Click "View/Page Source" from menu
4. View non HTML garbage characters

Actual Results:  
Garbage diaplayed on screen, no HTML is rendered. View source panel filled with
junk charavters.

Expected Results:  
Should display pages. View source should show HTML.

Thses sites are trivial in content, but should display nevertheless.
http://cgmeditrans.com sends only an Jpeg Image but it sends it as text/html and
Mozilla renders it as text/html. It's a "bug" (wanted bug) that IE shows you an
image.

Connecting to cgmeditrans.com[64.62.137.73]:80... connected.
HTTP request sent, awaiting response...
 1 HTTP/1.1 200 OK
 2 Date: Wed, 17 Sep 2003 20:25:18 GMT
 3 Server: Apache/1.3.28 (Unix) mod_auth_passthrough/1.8 mod_log_bytes/1.2 mod_b
wlimited/1.0 PHP/4.3.2 FrontPage/5.0.2.2634 mod_ssl/2.8.15 OpenSSL/0.9.6b
 4 Last-Modified: Sun, 06 Jul 2003 10:33:14 GMT
 5 ETag: "38682e-96b7-3f07fb00"
 6 Accept-Ranges: bytes
 7 Content-Length: 38583
 8 Keep-Alive: timeout=15, max=100
 9 Connection: Keep-Alive
10 Content-Type: text/html

-> TE

Reporter: Are you the owner os this domain ?
Assignee: other → english-us
Status: UNCONFIRMED → NEW
Component: Layout → English US
Ever confirmed: true
Product: Browser → Tech Evangelism
QA Contact: ian → english-us
Version: Trunk → unspecified
(Reporter)

Comment 2

16 years ago
from reporter: No I don't own this site. 

Was simply doing Editor work for DMOZ.ORG search engine data base and this was a
submission. I use Mozilla when doing editing because that puts Mozilla up
against a wide variety of tests. Sorry I am not technically savvy enough to have
discovered the jpeg-ness of the site. 

Hard to know whether Mozilla should interpret prissily or not in this case, i.e.
duplicate IE's "bug". I guess I'd lean on YES even though the web admin is at
fault.
No, Mozilla should not display it as image and you can't win the discussion (and
this has been discussed in other bugs ..)

There is no contact at the site and you can't do anything because you see only
this jpeg image. (the second URl is dead for me...)

Comment 4

16 years ago
If this is going to be a TE bug, then one of these domains should be spun off
into its own bug.

I would question whether it's worth the trouble to evangelize either site,
though, since there's "no there, there".  Both home pages are images that go
nowhere, do nothing.

Comment 5

16 years ago
the reporter can if he wishes. gonna mark this future and trivial
Severity: normal → trivial
OS: Windows XP → All
Hardware: PC → All
Summary: garbage characters displayed, looks like memory dump → cgmeditrans.com - image reported as text/html

Comment 6

15 years ago
This bug is fixed, or the content has changed. Both sites render with text.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.