double quotes in comments get crippled as "

RESOLVED INVALID

Status

()

Bugzilla
User Interface
--
minor
RESOLVED INVALID
15 years ago
5 years ago

People

(Reporter: Andreas Höfler, Assigned: myk)

Tracking

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b; MultiZilla v1.5.0.1) Gecko/20030827
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5b; MultiZilla v1.5.0.1) Gecko/20030827

When entering a comment which contains somewhere double quotes (""), these are
not displayed properly in the output later.

Reproducible: Always

Steps to Reproduce:
1. Enter a comment containing (") somewhere
2. Go back to the bug
3. The double quote changed to " in the comment.

Actual Results:  
(") -> (")

Expected Results:  
(") -> (")

I doubt that the quotes in this bug are displayed correctly, if anyone has
questions please contact me by mail for an example.
(Reporter)

Comment 1

15 years ago
Well, seems that the main Bugzilla has no problems with that, perhaps this has
something to do with the patch from Bug 102685, which I have installed at my
location.

Checking this, setting severity to minor because it seems to be a local problem.
Severity: major → minor
Yep.  Bugzilla::Wiki::GetWikiLinks() does this:

     $text = &::value_quote($text);

But it's called from inside QuoteUrls(), which does this:

    $text = html_quote($text);

So it's getting escaped twice.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.