HTM/JavaScriptL generated by Microsoft Visio is not working

VERIFIED DUPLICATE of bug 102131

Status

Tech Evangelism Graveyard
English US
VERIFIED DUPLICATE of bug 102131
15 years ago
3 years ago

People

(Reporter: Dominik Stadler, Unassigned)

Tracking

Details

Attachments

(1 attachment)

93.97 KB, application/x-zip-compressed
Details
(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030827
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030827

The flowcharting-application Microsoft Visio can export HTML-Pages from the
drawings. If there are multiple drawings in the Visio-File, the HTML contains
some JavaScript to provide a simple way to browse through the pages in a frame.
This code is not working, the browse-buttons and combo-box are not displayed.
The page works in IE.
This may well be a problem of the code and thus belong to Evangelism.

I will attach a zip-file with the files that are produced by Visio.

Reproducible: Always

Steps to Reproduce:
1. Extract the attached ZIP-File to a directory.
2. Open D_n_B_Architecture_frame.htm

Actual Results:  
The lower frame is completely black.

Expected Results:  
The lower frame should contain a combo-box with the available pages and left and
rigth buttons to navigate through them.

Comment 1

15 years ago
can you attach a reduced testcase via 'create a new attachment'
(Reporter)

Comment 2

15 years ago
Created attachment 131665 [details]
A ZIP-File that shows the bug

Comment 3

15 years ago
The JavaScript in "D_n_B_Architecture_utils.js" will only work in IE or NS4.

An example:

if (navigator.appName == "Netscape")
	{
	isNav = true;	
	layerStyleRef="layer.";
	layerRef="document.layers"; 
	styleSwitch=""; 
	}
else
	{ 
	isIE = true;
	layerStyleRef="layer.style."; 
	layerRef="document.all"; 
	styleSwitch=".style"; 
	}


-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
OS: Windows 2000 → All
Hardware: PC → All
Resolution: --- → INVALID
(Reporter)

Comment 4

15 years ago
Shouldn't this then be a bug for Evangelism to ask MS to change that? 

(regardless how unlikely it is that MS does really adjust this...)
Status: RESOLVED → UNCONFIRMED
Component: JavaScript Engine → English US
Product: Browser → Tech Evangelism
Resolution: INVALID → ---
Version: Trunk → unspecified

Comment 5

15 years ago
Setting default owner & QA
Assignee: rogerl → english-us
QA Contact: pschwartau → english-us

Comment 6

15 years ago
A bug already exists about the HTML that MS Office products output.  The MS web
site lists Visio as an Office component....

*** This bug has been marked as a duplicate of 102131 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → VERIFIED
Product: Tech Evangelism → Tech Evangelism Graveyard
You need to log in before you can comment on or make changes to this bug.