Image Manager incorrectly blocking thousands of sites

RESOLVED DUPLICATE of bug 215461

Status

()

Core
Image Blocking
--
major
RESOLVED DUPLICATE of bug 215461
14 years ago
14 years ago

People

(Reporter: Matt Fago, Assigned: Mitchell Stoltz (not reading bugmail))

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030917
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5) Gecko/20030917

Since switching to 1.5b I have been having images blocked from almost every site
I visit. I finally tracked down the problem: the "Image Manager" lists thousands
of sites as "cannot load images" -- yet I never specified this to be so!

I do not use "image manager" to block images from sites: I have "accept all
images" checked.

Yes, I can just remove the sites, but it takes several seconds to remove each
one (dunno why, it's just slow). Clicking on "Remove all sites" hung Mozilla for
over 45 minutes. So long that I killed it. Perhaps that is a seperate problem.

Nevertheless, something seriously odd is going on.

Reproducible: Always

Steps to Reproduce:

Actual Results:
(Reporter)

Comment 1

14 years ago
Changing to correct component.
Component: Browser-General → Image Blocking
Do you use the cookie manager to block cookies?
Did you use 1.4 after you used 1.5b, and then back to 1.5b again?

Can you post the cookperm.txt file from your profile (see the release notes for
the location)

This could be bug 215461
Assignee: general → security-bugs
(Reporter)

Comment 3

14 years ago
Created attachment 131682 [details]
cookperm.txt
(Reporter)

Comment 4

14 years ago
Yes, I do block lots of cookies, but not images. I may have used 1.4 once or
twice after switching to 1.5b -- don't remember.

I have been needing to re-block some cookies lately.

On a related matter:
Starting from a fresh ./.mozilla directory would probably be a good idea: I'm
running on the same one since Mozilla 0.92 or so, but really do not want to
loose some of my data. 

Is there an easy way to export and then re-import my password file (like one's
bookmarks)?

Comment 5

14 years ago
>Is there an easy way to export and then re-import my password file (like one's
bookmarks)?

I've used the instructions here successfully in the past:
http://burntelectrons.com/moz/moz-passwords.html
(Reporter)

Comment 6

14 years ago
Wow, just in time too -- somehow Mozilla created a new *.s file and "lost" all
of my saved passwords! Probably when I tried a nightly build too check on this
bug...

Thanks for the tip. Perhaps this should be in the Moz docs somewhere?
You can fix the cookperm.txt by removing the lines that start with %
I imported your cookperm.txt without that lines fine in a recent nightly.
(Reporter)

Comment 8

14 years ago
Thanks. I ended up just blowing cookperm.txt away and allowing Moz to re-build it.
anyway, buzilla isn't a helpdesk.
duping to bug 215461 which made loading cookperm.txt more robust. It is also
fixed on the 1.5 branch

*** This bug has been marked as a duplicate of 215461 ***
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.