checksetup.pl will run successfully only twice

RESOLVED DUPLICATE of bug 212095

Status

()

Bugzilla
Installation & Upgrading
RESOLVED DUPLICATE of bug 212095
14 years ago
5 years ago

People

(Reporter: Gary Beckmann, Assigned: zach)

Tracking

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030529

According to the user guide section 4.1.9
  "The checksetup.pl script is designed so that you can run it at any time
without       causing harm. You should run it after any upgrade to Bugzilla."

However, I can only run it twice.  Once to establish the localconfig and then
once to create the database.  If I run it again I get an error at the tokens table.

Reproducible: Always

Steps to Reproduce:
1.set up bugzilla (and after step defined in section 4.1.9.
2.cd <bugzilla-directory>
3../checksetup.pl

Actual Results:  
--- usual text ----

Creating table tokens ...
DBD::mysql::db do failed: Table 'tokens' already exists at ./checksetup.pl line
1636.
[Thu Sep 18 15:03:21 2003] checksetup.pl: DBD::mysql::db do failed: Table
'tokens' already exists at ./checksetup.pl line 1636.
Could not create table 'tokens'. Please check your 'mysql' access.


Expected Results:  
I believe it should check the database and tell me that all is "OK". 

Redhat 7.3
bugzilla 2.16.3
perl 5.6.1
mysql 3.23.49

Comment 1

14 years ago

*** This bug has been marked as a duplicate of 212095 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.