addresses in mailing list editor should be LTR even when the UI is RTL

RESOLVED FIXED

Status

SeaMonkey
MailNews: Address Book & Contacts
RESOLVED FIXED
15 years ago
10 years ago

People

(Reporter: Tsahi Asher, Assigned: standard8)

Tracking

(Blocks: 1 bug, {rtl})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; he-IL; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; he-IL; rv:1.4) Gecko/20030624

when using a language pack of a RTL language, like hebrew or arabic, the UI is
aligned left. when opening the mailing lists editor, the addresses in it are
also aligned right, although email addresses are in latin charactes. see bug
157607 comment 5 for discussion on the addresses in the message compose window,
where there is a similar type of data.

Reproducible: Always

Steps to Reproduce:
1.aligning the interface to the right: add these lines to the file intl.css, in
the locale\en-US\global, in the en-US.jar file (the language pack file, in the
chrome folder):

/*make UI RTL */

window,dialog,wizard,page { direction: rtl; }

menu { direction: rtl; }

outliner { direction: rtl; }

/*
 * make sure search from address bar remains in RTL
 */

#urlbar .autocomplete-search-engine
{
direction: rtl !important;
}

/*
 * keep Composer <HTML> Source tab LTR
 */

#content-source,
#doctype-text { direction: ltr; }

2. make sure you have a mailing list in the address bar
3. double click a mailing list, or select it and click the "properties" botton.

Actual Results:  
all addresses are aligned right

Expected Results:  
addresses should be aligned left

like in bug 157607, the css class uri-element should be added to the proper xul
file to fix this.
(Reporter)

Updated

15 years ago
Blocks: 219070

Updated

15 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Product: Browser → Seamonkey

Updated

13 years ago
Assignee: sspitzer → mail
(Assignee)

Updated

13 years ago
Assignee: mail → bugzilla
OS: Windows XP → All
Hardware: PC → All
(Assignee)

Comment 1

13 years ago
Created attachment 183850 [details] [diff] [review]
Patch v1 (Checked in)

This patch aligns the addresses on the mailing list dialog left even when rtl
is selected (applies to both suite & tb). Tested using the steps in comment 0.
I checked the new/edit card dialogs and they seem to have been done at some
earlier stage.

Tsahi: thanks for the useful testing info.
Attachment #183850 - Flags: superreview?(bienvenu)
Attachment #183850 - Flags: review?(bienvenu)
(Assignee)

Comment 2

13 years ago
David, any chance of you taking a look at the review for the attached patch
sometime?

Updated

13 years ago
Attachment #183850 - Flags: superreview?(bienvenu)
Attachment #183850 - Flags: superreview+
Attachment #183850 - Flags: review?(bienvenu)
Attachment #183850 - Flags: review+
(Assignee)

Comment 3

13 years ago
Comment on attachment 183850 [details] [diff] [review]
Patch v1 (Checked in)

Low risk patch to fix some LTR/RTL issues on seamonkey & thunderbird address
books.
Attachment #183850 - Flags: approval1.8b3?
Attachment #183850 - Flags: approval-aviary1.1a2?

Updated

13 years ago
Attachment #183850 - Flags: approval1.8b3?
Attachment #183850 - Flags: approval1.8b3+
Attachment #183850 - Flags: approval-aviary1.1a2?
Attachment #183850 - Flags: approval-aviary1.1a2+

Comment 4

13 years ago
Comment on attachment 183850 [details] [diff] [review]
Patch v1 (Checked in)

Checking in mailnews/addrbook/resources/content/abListOverlay.xul;
new revision: 1.21; previous revision: 1.20
mail/components/addrbook/content/abEditListDialog.xul;
new revision: 1.5; previous revision: 1.4
mail/components/addrbook/content/abMailListDialog.xul;
new revision: 1.5; previous revision: 1.4
done
Attachment #183850 - Attachment description: Patch v1 → Patch v1 (Checked in)
(Assignee)

Comment 5

13 years ago
Thanks to IanN for checking this in, this bug is now fixed.
(Assignee)

Comment 6

13 years ago
Err, looks like I forgot to mark this as resolved. Second attempt coming up...
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED

Comment 7

10 years ago
Mass-assigning the new rtl keyword to RTL-related (see bug 349193).
Keywords: rtl
You need to log in before you can comment on or make changes to this bug.