If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Update Installer to 1.5 in mozilla/config/milestone.txt for MOZILLA_1_5_BRANCH

VERIFIED FIXED

Status

SeaMonkey
Build Config
--
blocker
VERIFIED FIXED
14 years ago
6 years ago

People

(Reporter: Jacek Piskozub, Assigned: Daniel (Leaf) Nunes)

Tracking

({fixed1.5})

Other Branch
fixed1.5
Bug Flags:
blocking1.5 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

14 years ago
The value in milestone.txt is still 1.5b. This has already made us ship
mozilla1.5rc1 with wrong Release Notes link (bug 219566).

Marking as blocker per gerv comment in bug 219566.

Comment 1

14 years ago
taking a guess as to who this should be reassigned to, and cc'ing people that
may be relevant...
Assignee: mozbugs-build → leaf
Flags: blocking1.5?

Updated

14 years ago
Flags: blocking1.5? → blocking1.5+
Created attachment 131800 [details] [diff] [review]
Patch v.1

Change value to "1.5".

Gerv
Comment on attachment 131800 [details] [diff] [review]
Patch v.1

Requesting a rubberstamp r= from leaf.

Gerv
Attachment #131800 - Flags: review?(leaf)

Comment 4

14 years ago
*** Bug 219566 has been marked as a duplicate of this bug. ***
Comment on attachment 131800 [details] [diff] [review]
Patch v.1

Requesting r/sr from dbaron, given that he drove bug 219695 to completion.

Gerv
Attachment #131800 - Flags: superreview?(dbaron)
Comment on attachment 131800 [details] [diff] [review]
Patch v.1

Sure, but there might be some other version numbers that need updating too. 
I'm not sure how many of the ones listed in
http://mozilla.org/build/release-checklist.html still do.
Attachment #131800 - Flags: superreview?(dbaron)
Attachment #131800 - Flags: superreview+
Attachment #131800 - Flags: review?(leaf)
Attachment #131800 - Flags: review+
Created attachment 131918 [details] [diff] [review]
Patch v.2

dbaron: thanks for that pointer.

This updates all the files in that document which need updating except for
localeVersion and skinVersion, which I will leave (if necessary at all) to
people who know more about it than me.

Gerv
Attachment #131800 - Attachment is obsolete: true
Comment on attachment 131918 [details] [diff] [review]
Patch v.2

You need to know that I haven't compiled with these changes (not having access
to a Mac.) Changing strings really _shouldn't_ break anything, but...

Gerv
Attachment #131918 - Flags: superreview?(dbaron)
Comment on attachment 131918 [details] [diff] [review]
Patch v.2


>Index: xpinstall/wizard/mac/rsrc/MacInstallerVersion.r
>@@ -35,10 +35,10 @@
> resource 'vers' (2, "Mozilla Installer version") {
>         1,
>         0x40,

This line should be 0x50, judging by previous versions.

>-        alpha,	// {alpha, beta, release}
>+        release,	// {alpha, beta, release}
>         0,			// alpha or beta number; 0 for release
>         0,			// language
>-        "1.4a",		// short version string
>-        "Mozilla 1.4a Installer"	// long version string
>+        "1.5",		// short version string
>+        "Mozilla 1.5 Installer"	// long version string
> };
> 


>Index: xpfe/global/resources/locale/en-US/brand.dtd

Hold off on this until the localeVersion changes, I think.




With those changes, sr=dbaron.
Attachment #131918 - Flags: superreview?(dbaron) → superreview+

Comment 10

14 years ago
*** Bug 220023 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
Comment on attachment 131918 [details] [diff] [review]
Patch v.2

a=asa (on behalf of drivers) for checkin to the 1.5 branch. Please add the
fixed1.5 keyword when this fix lands on the branch.
Attachment #131918 - Flags: approval1.5+
Fix checked in to MOZILLA_1_5_BRANCH, 2003-09-23 15:36 -0700.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED

Updated

14 years ago
Keywords: fixed1.5
Product: Browser → Seamonkey
(Reporter)

Comment 13

12 years ago
Verifying per obviousness.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.