dragging scrollbar's thumb-tab stops working if another application puts a window in the foreground

RESOLVED DUPLICATE of bug 213122

Status

()

Core
Event Handling
--
minor
RESOLVED DUPLICATE of bug 213122
15 years ago
15 years ago

People

(Reporter: Dan Soper, Unassigned)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20030916
Build Identifier: Mozilla/5.0 (Windows; U; Win98; en-US; rv:1.5) Gecko/20030916

Excuse my shaky nomenclature..... By "thumb-tab" I mean the part of the
scrollbar whose size reduces to reflect the length of the page, and which you
can normally click-and-drag to scroll quickly through a page.

The bug I'm reporting occurs when another application jumps into the foreground
for whatever reason - by generating a pop-up window, for instance - while I'm
dragging that thumb-tab.

What happens is that dragging ceases to function. Other means of scrolling
(clicking above/below the thumb-tab, using the up/down buttons at the ends of
the srollbar, using the keyboard etc.) do still work.

The problem goes away when I go to a different page, and only affects the
current tab. Clicking the Back button followed by the Forward button is an easy
work-around (unless the page I'm reading is the first to be loaded in its
tab/window, in which case the work-around is to click any link in the page,
followed by the Back button).

Reproducible: Always

Steps to Reproduce:
1. visit any web page that's long enough for Mozilla to have a scrollbar
2. arrange for another application to genrate a pop-up window which you're
dragging the thumb-tab on the scrollbar.
3. dismiss the pop-up or return focus to the Mozilla window, and try to resume
scrolling through the page as before

Actual Results:  
Nothing. The thumb-tab changes colour when I click on it, as normal, but stays
put when I try to drag it.

Expected Results:  
Scrolling as the mouse is moved, as happened before the pop-up popped up.

First seen by me in Mozilla 1.5 beta; also present in 1.5rc1.
(Reporter)

Comment 1

15 years ago
Correction to Steps to Reproduce:

2. arrange for another application to genrate a pop-up window WHILE you're
dragging the thumb-tab on the scrollbar.


I should proof-read better. :-)


d.
(Reporter)

Comment 2

15 years ago
Update: this seems to apply only to a vertical scrollbar. A pop-up appearing
while scrolling a horizontal scrollbar does not have the effect I described earlier.

Comment 3

15 years ago
This has been fixed in the nightly trunk builds and is being considered for
Mozilla 1.5 final too.

*** This bug has been marked as a duplicate of 213122 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.