link in table is unclickable

VERIFIED DUPLICATE of bug 102695

Status

()

Core
CSS Parsing and Computation
VERIFIED DUPLICATE of bug 102695
15 years ago
15 years ago

People

(Reporter: GQ, Assigned: dbaron)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

I found strange situation when <a ...> link become unable to click. An example
of HTML code with that bug is in attachment

Reproducible: Always

Steps to Reproduce:
1.Load example
2.Click on the link
Actual Results:  
Nothing happends (mouse cursor doesn't looks like cursor over link too)

Expected Results:  
Link should be activated.
(Reporter)

Comment 1

15 years ago
Created attachment 131792 [details]
page with example of bug

Comment 2

15 years ago
this code shows better what's going on:

<html>
<head>
<style type="text/css">
span { border:1px solid black}
table {border:1px solid red}
</style>
</head>
<body>
<table border="0" cellpadding="2" cellspacing="0">
<tbody><tr><td><a href="http://nowere.org">Link wich cant be clicked cause of
bug.</a></td></tr>
</tbody></table>
<span style="padding: 50px;">
buggi element
</span>
</body></html>

the padding of the span makes it place over the table, I don't think that this
behaviour is right, but I'm not so sure as to confirm it.

(tested with 1.5RC1, wXP)

Comment 3

15 years ago
Adding two <br> between </table> and <span> the link was working,
adding one <BR> only the link was not working, but worked, when I reduced the
padding of the span from 50 to 5.
(Assignee)

Comment 4

15 years ago
If you put a background on the span, you'll see what's going on.

Marking duplicate of bug that's borderline-invalid and likely not to be fixed.


*** This bug has been marked as a duplicate of 102695 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.