Make File-> Open support both URLs and local files

VERIFIED WONTFIX

Status

()

Firefox
Menus
--
enhancement
VERIFIED WONTFIX
14 years ago
11 years ago

People

(Reporter: Daniel Jackson, Assigned: mconnor)

Tracking

(Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030901 Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030901 Firebird/0.6.1+

A new user without (or unable to use) a mouse, cannot know how to type in an
address in Firebird.

This is perhaps the most important feature of the browser, and a new non-mouse
user will not know how to get to the 'address' field, as they cannot know what
the shortcuts are.

Reproducible: Always

Steps to Reproduce:
1. Find a new user unable to use or without a mouse
2. Ask them to type go to a specific website

Actual Results:  
They will not know how to specify a URL.


Expected Results:  
The user should have been able to use EITHER:

   1. File|Open (Ctrl+O)

or 2. A new menu item: Go|Specify Location (Ctrl+L) -- to find out the shortcut
for future reference

or 3. The address bar should have the label A_d_dress (underlined d) to indicate
they can use Alt+D as a shortcut


A new keyboard-only user cannot know how to specify an address.  Yes, they're
mentioned at http://texturizer.net/firebird/keyboard.html -- but the new user
won't be able to type that address!

1. Keyboard users other browsers may be used to File|Open (Ctrl+O) allowing them
to specify an arbitrary URL (in addition to specifying a local file) -- after
all, this is a web browser!  This solution would provide the least additional
clutter as the menu item already exists (but is only able to open files).

2. A less desirable alternative (as it's another menu item) would be to add an
item for Ctrl+L on the "Go" menu.  This seems pointless as File|Open could do this.

3. Another alternative (less desirable for screen-space reasons) could be an
"Address" label with underlined "d" illustrating that Alt+D may be used.

NOTE: The perfect dialog box for solution 1 can already be seen in FB by typing
Ctrl+L when the address bar is hidden.
(Reporter)

Comment 1

14 years ago
This bug should actually be an RFE, and "Severity" should be changed to
"Enhancement"
(Reporter)

Updated

14 years ago
Severity: normal → enhancement
(Reporter)

Comment 2

14 years ago
Additionally, a user can tab to the address bar, but this may take a long time
depending on the number of tab-stop elements on a page -- especially if an input
box has been focussed by a script.

Updated

14 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

14 years ago
This bug is either INVALID or WONTFIX.

1. The link to keyboard shortcuts is easily accessible on the firebird start page
   that every newbie will see when he starts firebird the first time. He can then 
   tab to the link or use "find as you type" to get there.
2. Second and much more important:
   Firebird works only on a graphical user interface and a mouse is essentially 
   required to use any common GUI that I'm aware of. Most GUI's and programs 
   provide means to get to the functionality via keyboard, but without a mouse 
   you are essentially doomed and not knowing how to get to the location bar in 
   firebird is your least problem in this case.

CC'ing some qa's to get their opinion.
(Reporter)

Comment 4

14 years ago
Regarding Comment #3 --

Point 1: A "new user" could be using an already-installed Firebird, hence a
different homepage could have been set up.

Point 2: A mouse is far from "required" in most modern GUIs.  Accessibility is
important for everyone, but especially for people who can't use a mouse.


I think the easiest soulution would just be a File|Open that let you open a file
regardless of whether it's local or remote (this is a web browser after all!)
(Assignee)

Comment 5

14 years ago
accessibility is required for section 508 compliance, so saying you need a mouse
won't wash.  However, if someone sets up the program for someone, the odds are
that they will also show them how to use said program.  Adding UI for an edge
case such as you are describing is not needed under these circumstances.

For those switching from IE, Alt-D, Ctrl-L, and F6 are all key-compatible.  (We
don't support Ctrl-Tab, but that is used for cycling tabs.)  I doubt there is
much of an accessibility userbase that isn't using IE or won't be able to read
the docs regarding this.

Tweaking summary to reflect what was effectively being requested.

-> WONTFIX, we don't need to add UI to cover what documentation already covers.
Status: NEW → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → WONTFIX
Summary: New user without a mouse can't know how to specify a URL → Restore File->Open Location for accessibility users

Comment 6

14 years ago
verified wontfix.
Status: RESOLVED → VERIFIED

Comment 7

14 years ago
I don't agree with the reasons for WONTFIX'ing this rfe. In my opinion, Ctrl+O,
the standard shortcut for opening documents, should also accept URI's.

The startpage has now changed, so new users can't see the keyboard shortcut list
as easily anymore. The "much more important" argument that Firebird only works
on a GUI environment is not an argument at all. That has nothing to do with
accessibility or keyboard shortcuts.

Comment 8

14 years ago
Yeah, reopening because the homepage has changed. I'm also tweaking the summary
a little bit and add a dependency.
Blocks: 204402
Status: VERIFIED → REOPENED
Resolution: WONTFIX → ---
Summary: Restore File->Open Location for accessibility users → Restore File->Open Location for better keyboard accessibility
(Reporter)

Comment 9

14 years ago
IMO, it makes no difference what the default homepage is.

Many target users will be people in e.g. companies/libraries/schools who will be
using an already-installed copy, most probably with a different homepage already
set.

FB needs to be accessible and obvious to use *at all times*, not just the first
time you start it.
(Assignee)

Comment 10

14 years ago
actually, obvious and accessible "at all times" is a silly myth that stems from
the "it has to be discoverable" school of thought.  Large companies that
transition users to a new piece of software ALWAYS have training etc to deal
with new software, its not like they say "hey, use this new web browser, have
fun!" (If you work for a large company that does this, let me know so I can sell
their stock)  Also, people who really need keyboard accessibility will almost
always have special training, and/or use IE already and can use those shortcuts.

Now, what I would buy into is making File->Open File into File->Open and
tweaking the Open Web Location dialog into something that can obviously be used
to open files AND URLs.  Of course, I need to test this on Linux before I could
say its usable as a cross-platform solution, but its a logical solution.

-> taking to determine if a sane File->Open dialog is possible cross-platform
Assignee: blake → mpconnor
Status: REOPENED → NEW
(Assignee)

Comment 11

14 years ago
probably sane, need to test on Linux and probably get a Mac tester before I
really can be sure this is plausible (there's got to be some sane reason why
this was separate in the first place)
Priority: -- → P3
Summary: Restore File->Open Location for better keyboard accessibility → Make File-> Open support both URLs and local files
Target Milestone: --- → Firebird0.9
(Assignee)

Comment 12

14 years ago
brought up on IRC, hyatt doesn't want a combined dialog, I agree with his
reasoning, since it effectively makes opening a local file more mouse/keyboard
intensive.

restoring WONTFIX, do not reopen unless you're hyatt :)
Status: NEW → RESOLVED
Last Resolved: 14 years ago14 years ago
Priority: P3 → --
Resolution: --- → WONTFIX
Target Milestone: Firebird0.9 → ---

Comment 13

14 years ago
So be it. Verifying.
Status: RESOLVED → VERIFIED

Updated

11 years ago
QA Contact: bugzilla → menus
You need to log in before you can comment on or make changes to this bug.