can't use HTML character entities in CSS text

RESOLVED DUPLICATE of bug 204324

Status

()

Core
HTML: Parser
--
minor
RESOLVED DUPLICATE of bug 204324
15 years ago
15 years ago

People

(Reporter: Mikel Ward, Assigned: harishd)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
I tried to place a right arrow (→) at the start of a particular list
using the following CSS rule:
#menu > ul > li > ul:before { content: "→"; }

This rule was included in a separate stylesheet file linked using
<link rel="stylesheet" type="text/css" href="/styles/menu-topbar.css"
  title="Topbar Menu" />

In Opera 7, a right arrow appears before the list as expected.  In Mozilla
Firebird 0.6.1, the text &rarr; appears rather than the right arrow character.

I have not verified that this behavior is part of the CSS standard, however
it seems logical to me that anywhere a text string can be, it can include
HTML/SGML character entities as well as character literals.

On the page I refer to, I have replaced the "&rarr;" with a greater than
sign to work around the problem.

Comment 1

15 years ago
It's not supposed to work that way.  Entities are not sent to be parsed.  See
the dup'ed bug for more and how to properly do it.

*** This bug has been marked as a duplicate of 204324 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.