Closed Bug 219853 Opened 16 years ago Closed 16 years ago

:hover selector not functionning in quirk mode, when no tagname specified

Categories

(Core :: CSS Parsing and Computation, defect)

x86
Windows 2000
defect
Not set

Tracking

()

RESOLVED DUPLICATE of bug 197686

People

(Reporter: freddy, Assigned: dbaron)

References

()

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030916
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5) Gecko/20030916

In the page http://www.forum82.org/css_hover.html, the background-color of div
does not change when the mouse over it, despite the .foo:hover selector. The
problem is not present in standard compliance mode (ie by adding a correct
doctype to the html page)

Reproducible: Always

Steps to Reproduce:
1. Display the page linked
2. Hover the text

Actual Results:  
Nothing

Expected Results:  
Changing of background-color of the div (according to css rule)

Changing selector to div.foo:hover prevent the problem, switching to standard
compliance mode too.
intentional for compatibility with IE. Use standards mode.
Status: UNCONFIRMED → RESOLVED
Closed: 16 years ago
Resolution: --- → WONTFIX
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 197686
You need to log in before you can comment on or make changes to this bug.