Table pushed below by three weird elements

RESOLVED INVALID

Status

()

Core
Layout: Tables
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: Michele Bugliaro, Unassigned)

Tracking

Trunk
PowerPC
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030917 Camino/0.7+
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.5b) Gecko/20030917 Camino/0.7+

I've an html file with simple CSS that, only under Camino, has this weird problem.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.




<html>
<head>
<title>::All my passwords::</title>
<meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1">
<style type="text/css">
<!--
.decobasic {font-family: Arial, Helvetica, sans-serif; font-size: 12px;
font-style: normal; border: none; background-color: #FFFFFF; color: #333333;}
.decocells {font-family: Arial, Helvetica, sans-serif; font-size: 12px;
font-style: normal; background-color: #003366; font-weight: bold; color:
#FFFFFF; border: none #990000; text-align: left;}
.textbold {font-family: Arial, Helvetica, sans-serif; font-size: 12px; color:
#006699; font-weight: bold;}
.table {border: 1px dashed #003366; background-color: #FFFFFF;}
.texttitle {font-family: Arial, Helvetica, sans-serif; font-size: 13px;
font-weight: bold; color: #FFFFFF; background-color: #006699;}
-->
</style>
</head>
<body link="#000099" vlink="#000033" alink="#0066FF" leftmargin="0"
topmargin="0" marginwidth="0" marginheight="0">
<table width="500" height="3500" border="0" align="center" cellpadding="0"
cellspacing="0" class="table">
  <tr>
    <td height="18" class="decocells">MAC OS X ACCESS</td>
  </tr>
(Reporter)

Comment 1

15 years ago
Created attachment 131833 [details]
That's the problem.

See part of HTML code previously included.

Comment 2

15 years ago
That HTML fragment isn't enough to reproduce the problem. Could you please attach the complete 
file? (With private information removed, of course.)
(Reporter)

Comment 3

15 years ago
Created attachment 131896 [details]
Whole html document (without private infos)
(Reporter)

Comment 4

15 years ago
Added requested document.

Comment 5

15 years ago
I can confirm this now, but Mozilla 1.5b renders it the same as Camino, so the Product should be 
Browser.
not camino if it happens in moz1.5b
Assignee: pinkerton → table
Status: UNCONFIRMED → NEW
Component: Page Layout → Layout: Tables
Ever confirmed: true
Product: Camino → Browser
QA Contact: madhur
Version: unspecified → Trunk

Comment 7

15 years ago
That's because you have these invalid:

<span class="table"> </span>

Between TR rows throughout the page.  Take them out and the page renders fine.
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
(Reporter)

Comment 8

15 years ago
I confirm: case closed. Thanks.
You need to log in before you can comment on or make changes to this bug.