Crash in nsEventStateManager while loading IMAP message

VERIFIED WORKSFORME

Status

P3
normal
VERIFIED WORKSFORME
19 years ago
14 years ago

People

(Reporter: kinmoz, Assigned: joki)

Tracking

({crash})

Trunk
x86
Windows NT
crash

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

19 years ago
I clicked on an IMAP message that was taking a long time to load. It was a
message from marek that contained a bugsplat query.

Anyways, I clicked out of the mail window into a DOS prompt window, then clicked
on the mail window to bring it to the foreground again, and then I crashed with
the following stack trace. Cc'ing saari and joki since crash is in
nsEventStateManager.cpp.


nsXULElement::GetTag(const nsXULElement * const 0x03249260, nsIAtom * &
0xdddddddd) line 2018 + 10 bytes
nsEventStateManager::CheckDisabled(nsIContent * 0x03249260) line 872
nsEventStateManager::UpdateCursor(nsIPresContext * 0x05fd4de0, nsPoint & {...},
nsIFrame * 0x040dc44c, nsEventStatus * 0x0012fa74) line 897 + 29 bytes
nsEventStateManager::PreHandleEvent(nsEventStateManager * const 0x03941070,
nsIPresContext * 0x05fd4de0, nsGUIEvent * 0x0012fb68, nsIFrame * 0x040dc44c,
nsEventStatus * 0x0012fa74, nsIView * 0x03968600) line 187
PresShell::HandleEvent(PresShell * const 0x05f99534, nsIView * 0x03968600,
nsGUIEvent * 0x0012fb68, nsEventStatus * 0x0012fa74) line 2628 + 43 bytes
nsView::HandleEvent(nsView * const 0x03968600, nsGUIEvent * 0x0012fb68, unsigned
int 8, nsEventStatus * 0x0012fa74, int & 0) line 841
nsView::HandleEvent(nsView * const 0x03968ec0, nsGUIEvent * 0x0012fb68, unsigned
int 8, nsEventStatus * 0x0012fa74, int & 0) line 826
nsView::HandleEvent(nsView * const 0x05f99a30, nsGUIEvent * 0x0012fb68, unsigned
int 28, nsEventStatus * 0x0012fa74, int & 0) line 826
nsViewManager::DispatchEvent(nsViewManager * const 0x05f99c00, nsGUIEvent *
0x0012fb68, nsEventStatus * 0x0012fa74) line 1678
HandleEvent(nsGUIEvent * 0x0012fb68) line 69
nsWindow::DispatchEvent(nsWindow * const 0x03968d94, nsGUIEvent * 0x0012fb68,
nsEventStatus & nsEventStatus_eIgnore) line 421 + 10 bytes
nsWindow::DispatchWindowEvent(nsGUIEvent * 0x0012fb68) line 442
nsWindow::DispatchMouseEvent(unsigned int 300, nsPoint * 0x00000000) line 3332 +
21 bytes
ChildWindow::DispatchMouseEvent(unsigned int 300, nsPoint * 0x00000000) line
3550
nsWindow::ProcessMessage(unsigned int 512, unsigned int 0, long 1376901, long *
0x0012fdc8) line 2620 + 24 bytes
nsWindow::WindowProc(HWND__ * 0x00bb0916, unsigned int 512, unsigned int 0, long
1376901) line 608 + 27 bytes
USER32! 77e71250()
00150285()
(Reporter)

Comment 1

19 years ago
Forgot to mention that I'm using a 12/16/1999 debug build.
(Reporter)

Comment 2

19 years ago
Created attachment 3552 [details]
Message I was loading when the crash happened.

Comment 3

19 years ago
saari or joki, could one of you take this?

Updated

19 years ago
Assignee: phil → joki

Comment 4

19 years ago
Reassign to joki
Summary: Crash in nsEventStateManager while loading IMAP message → [CRASH] Crash in nsEventStateManager while loading IMAP message
Marking [CRASH].
(Assignee)

Comment 6

19 years ago
Moving crash bugs into M13.
(Assignee)

Updated

19 years ago
Target Milestone: M13 → M14
(Assignee)

Comment 7

19 years ago
Mass-moving excess bugs to M14

Comment 8

19 years ago
Adding "crash" keyword to all known open crasher bugs.
Keywords: crash

Updated

19 years ago
Summary: [CRASH] Crash in nsEventStateManager while loading IMAP message → Crash in nsEventStateManager while loading IMAP message
(Assignee)

Comment 9

19 years ago
Hmm.  Well I can't reproduce the problem exactly.  We've seen some other 
problems of similar type that we've fixed but they didn't match this exactly.  I 
wish I had a better solution but I'm going to have to mark this WORKSFORME for 
lack of a better answer.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → WORKSFORME

Comment 10

19 years ago
kin - have you seen this problem recently on any other type of messages as 
you're using mail/IMAP? thanks.

Comment 11

19 years ago
I am marking verified since this is an old bug report and no one with a debug 
build has reopened it.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.