Replace IE executable with a pointer to Moz/FB on Windows

VERIFIED WONTFIX

Status

SeaMonkey
General
--
enhancement
VERIFIED WONTFIX
15 years ago
13 years ago

People

(Reporter: Waldo, Assigned: Sean Su)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030916 Firebird/0.6.1+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5b) Gecko/20030916 Firebird/0.6.1+

One good program I've found online called NoteTab Light (a beefed-up plain text
editor) has an interesting feature called Replace Notepad.  Basically, what it
does is it renames notepad.exe to something else and creates a new notetab.exe
that is just an executable pointer to the NoteTab program file.  Reverting to
using Notepad just involves deleing the pointer file and renaming the original
Notepad.  This feature allows you to use it instead of Notepad without changing
a bunch of file type settings.

I propose creating a similar feature for Mozilla/Firebird that allows a Windows
user to replace the Internet Explorer program file with an executable pointer to
the Mozilla/Firebird executable file.  In general this would not be a very
useful feature as each browser has simple settings to make it default.  The
problem comes only with miswritten apps: for example, I occasionally use Netzero
to connect to the Internet, and when Netzero has connected and is loading a
start page, it looks specifically for IE to load it, ignoring default browser
settings.  (I've sent Netzero some feedback on this but have received no
response.)  If I were able to replace IE with a pointer to Mozilla/Firebird,
this would not be a problem.

I realize this is a very specific problem that really only applies when poorly
written apps that want to access the Internet are used, but for me it is an
annoyance.  Might this feature possibly be added, or should I continue pestering
Netzero?  I can understand a WONTFIX if this gets one.

Reproducible: Always

Steps to Reproduce:




If this is considered, it may be unfeasible on XP due to XP's System File
Protection, although replacing Notepad has worked on my XP system.
Actually, the more I think about this, this should really be a preference and
not part of the install process.  Changing component to Browser-General because
I can't find a better component.
Component: Installer → Browser-General

Comment 2

15 years ago
Let's not break other programs! We're not gonna be bigger be replaing other
vendors exe files.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → WONTFIX
v
(got a mid-air with this)

For example windowsupdate would be broken with this.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.