New Mail icon behaves erratic with new mail

RESOLVED DUPLICATE of bug 222068

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 222068
15 years ago
10 years ago

People

(Reporter: Frank Fridlund, Assigned: (not reading, please use seth@sspitzer.org instead))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916

Found in Mozilla 1.5RC1:
When a new mail message comes into Mozilla, the notification saying 'xxx has 1
new message(s)' followed by the new mail icon in the taskbar.  As I read my new
mail messages, the icon does not disappear from the system tray, long after the
messages have been marked as read.

Reproducible: Sometimes

Steps to Reproduce:
1. Open MailNews
2. Switch to another window (like Browser)
3. Receive e-mail
4. Switch to MailNews and read new e-mail
5. Look at taskbar

Actual Results:  
the new mail icon didn't disappear

Expected Results:  
It should disappear when the first new message was being read

One time while I was clicking on the icon, the icon did go away somehow, but it
never showed again when the notification came up for new mail.  The only way to
fix it was to close all Mozilla windows and restart.

Comment 1

15 years ago
I have seen this happen as well. It doesn't seem to go away until I check for
new messages.

The other thing that bugs me about the new mail icon behavior is that if you
have filters that delete email, and all the email that just arrived new is
deleted, you still get the new mail icon! It won't be cleared until you check
for new mail.

I am using IMAP, so my guess is the code is not taking into account that I have
deleted this emails, since technically they are still in my inbox until I
"compact folders."

The new mail icon should only remain in the task bar as long as there are unread
messages in any folders EXCEPT the Junk/Trash folders, and so long as those new
messages are not marked in IMAP for deletion. 

Comment 2

14 years ago
Frank S, are you also using IMAP?

Regarding deleted mails: even with POP mail, using a filter that deletes the 
message will cause a notification (bug 91498).  There are many bugs relating to 
the use of the Mark As Deleted model of IMAP.

The new mail icon in the taskbar (and also, the green-arrow on the Mail icon in 
the Mozilla Component Bar, bottom left of each Mozilla window) is supposed to 
clear as soon as any indication is made by the user that new mail has been 
acknowledged -- not just reading the new mail, but even just switching to a 
folder in an account that has new mail.  I have not seen a case with my POP3 
accounts where that icon does not clear as soon as I do practically anything.
(Reporter)

Comment 3

14 years ago
I'm just using a simple POP account, with only a couple filters to move
messages, and no delete filters.  

Comment 4

14 years ago
The new mail icon does clear if I click on the inbox folder, but the problem is
I get a lot of email that is deleted by filters (currently, a bug in our mail
system is generating email and I don't have time to fix it, but other things
like that come up). What happens is you then have to look at the mail program,
because it claims there is new mail present, when actually it has been deleted.

Comment 5

14 years ago
If you use filters to move/delete mails, then I think it is a dupe of Bug 222068.
(Reporter)

Comment 6

14 years ago
Yeah.  After reading that bug more carefully and doing some tests, it is
actually a dupe of bug 222068.  Sorry about that.

*** This bug has been marked as a duplicate of 222068 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Browser → Seamonkey

Updated

10 years ago
Component: MailNews: Notification → MailNews: Message Display
QA Contact: stephend → search
You need to log in before you can comment on or make changes to this bug.