entering :// as the URL causes the browser to become unresponsive and consume all available CPU time but not terminate

VERIFIED DUPLICATE of bug 185663

Status

SeaMonkey
Location Bar
--
minor
VERIFIED DUPLICATE of bug 185663
14 years ago
9 years ago

People

(Reporter: Timothy Dyck, Assigned: Joe Hewitt (gone))

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.4) Gecko/20030624

Entering

   ://

as a URL in the location bar and pressing Enter results in the browser consuming
all available CPU time (100% utilization overall) and becoming unresponsive to
user input. It does not crash. To quit, I must terminate the process.

Reproducible: Always

Steps to Reproduce:
1. Enter :// as the URL
2. Press Enter


Actual Results:  
Browser becomes unresponsive to all user input.

Expected Results:  
Display an error message.

*** This bug has been marked as a duplicate of 185663 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
verified.
Status: RESOLVED → VERIFIED
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.