bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

INTERNAL ERROR on Browser End: JavaPluginInstance5::GetValue - Not implemented

RESOLVED DUPLICATE of bug 219705

Status

Core Graveyard
Java: OJI
--
critical
RESOLVED DUPLICATE of bug 219705
15 years ago
8 years ago

People

(Reporter: walter sheets, Assigned: Joshua Xia)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030805
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030805

Java broke with some commits made during the half-hour between
"15 Sep 2003 17:30 PST" and "15 Sep 2003 18:00 PST"

The URL above is for a java app which draws real-time price
charts for currency traders at lindforex.com.  This app works
perfectly with mozilla/firebird built from sources before
Sep 15 at 17:30, but since then the browser crashes with the
'internal error' message while loading the java app.

I'm using this java plugin, but the version doesn't seem to matter: 
/opt/sun-jdk-1.4.2.01/jre/plugin/i386/ns610-gcc32/libjavaplugin_oji.so


Reproducible: Always

Steps to Reproduce:
1.Go to the URL above
2.
3.

Actual Results:  
mozilla crashes while loading the java app
(worked great until Sep 15, 2003).  The same
bug appeared in Firebird at the same time --
not surprising I guess.



Expected Results:  
Draw realtime price charts for currency traders.

I see the error message only when starting mozilla from the
command line.  There is no coredump.

Here's my mozconfig:
mk_add_options MOZ_CO_DATE="15 Sep 2003 18:00 PST" (bug appears at this time)
ac_add_options --enable-default-toolkit=gtk2
ac_add_options --enable-crypto
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --disable-ldap
ac_add_options --enable-strip
ac_add_options --enable-strip-libs
ac_add_options --enable-optimize="-O -march=athlon -pipe"
ac_add_options
--enable-extensions=default,-inspector,-irc,-venkman,-content-packs,-help
ac_add_options --without-system-nspr
ac_add_options --without-system-jpeg
ac_add_options --without-system-zlib
ac_add_options --without-system-png
ac_add_options --disable-freetype2
ac_add_options --enable-xft
You use the Java plugin itself and not a plugin written in Java -> Oji
Assignee: idk → joshua.xia
Component: Java-Implemented Plugins → OJI

Comment 2

15 years ago

*** This bug has been marked as a duplicate of 219705 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Updated

8 years ago
Component: Java: OJI → Java: OJI
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.