[Webshell Print] [CRASH][BLOCKER] Password field in form crashes browser when printed

VERIFIED DUPLICATE of bug 21470

Status

()

P3
blocker
VERIFIED DUPLICATE of bug 21470
19 years ago
19 years ago

People

(Reporter: shrir, Assigned: dcone)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

19 years ago
I used today's comercial builds (Win, Mac, Unix)
Found out that the HTML form tag "<input type="password">" makes the browser
crash. To recreate the problem, please follow these steps:

1. Copy the following text and save it as an HTML file on your machine.

--------here-----------
<html>
<body>
<form name="passwordform" action="xx" method="yy">
<input type="password" name="passwd">
</form>
</body>
</html>
-------here------------

2. Open this file from the browser using the "File|Open File menu option.
3. A page with an HTML password field at top appears.
4. Use the "File |Print" menu to print the page.
5. Observe that the browser crashes but the page prints.
(Reporter)

Comment 1

19 years ago
Created attachment 3553 [details]
Stack trace for crash on Windows
(Reporter)

Comment 2

19 years ago
I think this same problem makes the "infoseek.com" page crash  (bug 21763). Don,
could you please comment?
(Reporter)

Comment 3

19 years ago
Created attachment 3575 [details]
Attached test case
(Assignee)

Updated

19 years ago
Status: NEW → ASSIGNED
Summary: [CRASH][BLOCKER] Password field in form crashes browser when printed → [Print Fail CRASH][BLOCKER] Password field in form crashes browser when printed
Target Milestone: M13
(Assignee)

Updated

19 years ago
Summary: [Print Fail CRASH][BLOCKER] Password field in form crashes browser when printed → [Print Webshell] [CRASH][BLOCKER] Password field in form crashes browser when printed
(Assignee)

Comment 4

19 years ago
This is a webshell problem.. the GFXTextcontrol is expecting a Webshell for a
parent..
(Assignee)

Updated

19 years ago
Summary: [Print Webshell] [CRASH][BLOCKER] Password field in form crashes browser when printed → [Webshell Print] [CRASH][BLOCKER] Password field in form crashes browser when printed
(Assignee)

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 5

19 years ago
GFXTextcontrolframe is a same problem as in 21470

*** This bug has been marked as a duplicate of 21470 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 6

19 years ago
Okay, bug 21470 deals with missing webshells, which involves this bug.  Marked
as verified.
You need to log in before you can comment on or make changes to this bug.