print preview shows only one of two pages, second page is not accessible in preview

RESOLVED DUPLICATE of bug 247166

Status

()

RESOLVED DUPLICATE of bug 247166
15 years ago
15 years ago

People

(Reporter: diptvtv, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1

If you go to http://register.epoline.org/espacenet/ep/en/srch-reg.htm and enter
ep800800 in the first input field (Publicatino Number / Date) and then click on
submit you will the some data of a European Patent in the actuell window. If you
then select "print preview" only one page with about 3/4 of the page content is
shown. The rest of the page is not accessable in print preview. In the toolbar
of the preview window it says "page 1 of 1" which is not true.
If you print the page the whole content is printed on two pages.
IE 6.0 shows the correct number or pages in print preview. In fact one can chose
whether the page should be shown as on the sreen (with scrollbars) or only the
selected frame should be shown (which results in the complete contents on two pages)

Reproducible: Always

Steps to Reproduce:
see above
Actual Results:  
Only one page is shown in print preview

Expected Results:  
It should show two pages with the whole content.

Comment 1

15 years ago
I was able to reproduce this bug. It seems to happen to all of the patent info
available at the site.

It's worth noting that the site uses javascript document.write to generate all
of the content.

User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6b)
Gecko/20031114 Firebird/0.7+

Comment 2

15 years ago
Confirming and triaging.
Assignee: blake → core.printing
Status: UNCONFIRMED → NEW
Component: General → Print Preview
Ever confirmed: true
Product: Firebird → Browser
Version: unspecified → Trunk

Comment 3

15 years ago
Created attachment 145806 [details]
alternate source that shows specified behavior

What I did was selected the whole page, chose 'view selection source' to view
the generated source for the page (that is, after the document.write's
execute), and copied this to a new page.  I then enclosed that page inside a
frame.	If you load up the bug220002-testcase.html file and do a print preview,
you will see the exact same problem as described before.

This file isn't stricly a testcase, but it does show that the problem lies not
with the javascript but with the FRAME tag.

Also, in the page, note that when you scroll up or down with your mouse, parts
of the page get garbled.  Some other things to note: you can click on the
drop-down box and view the other options, you can right click on links and the
context menu will show options like 'open in new tab' (although nothing happens
if you click on it), and right clicking and hitting 'reload' will crash
Mozilla.  These other things may be covered in other bugs.

Comment 4

15 years ago
I've recognized this as another bug I've worked on, bug 239795.  My testcase 3
there applies to this bug.  I recommend that this bug be marked as a dupe of
that one, since more work has been done on it already.

Comment 5

15 years ago
There's been no objections to my last comment, so I'm resolving this as a dupe
as planned.  Feel free to reopen if you disagree.

*** This bug has been marked as a duplicate of 239795 ***
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → DUPLICATE

Comment 6

15 years ago
reopening just to change dupe
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---

Comment 7

15 years ago

*** This bug has been marked as a duplicate of 247166 ***
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.