Sending mail (IMAP) with save to "Sent" folder (on server), with no "Sent" folder on the server -> error "Permission denied."

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
15 years ago
5 years ago

People

(Reporter: edgrale, Unassigned)

Tracking

({qawanted})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b) Gecko/20030917 Firebird/0.6.1+
Build Identifier: Mozilla Thunderbird 0.3a (20030917) ftp://ftp.mozilla.org/pub/thunderbird/nightly/2003-09-17-1.5/

Hello,

I had a "new" account with no additional folders than "Inbox", so I had the
settings for it to store sent message to the "Sent" folder on my ISP server. Lo
and behold, it gives me an error:

"The current command did not succeed. The mail server responded: Permission denied"

So, I tried a few times and then it hits me, for some reason Thunderbird does
not create the folder. So I manually create it and now it works.

ps. Thunderbird 0.3a (20030917) does create the "Junk" folder.

Reproducible: Always

Steps to Reproduce:
1. Remove the "Sent" folder from the server.
2. Send a mail to someone with the save to "Sent" folder, pointing at your server.
3. Should produce an error.

Actual Results:  
Gives me an error:

"The current command did not succeed. The mail server responded: Permission denied"


Expected Results:  
Told me that the folder does not excist and asked if I wanted Thunderbird to
create one.
(Reporter)

Comment 1

15 years ago
Still a bug in Mozilla Thunderbird 0.3 (20030923)

Comment 2

13 years ago
Reporter, can you please try reproduce this error on a newer build?

Comment 3

13 years ago
I can also confirm this bug using the build for 10/15 and it is still there.
This is occuring in both the Windows and Mac version. I will supply additional
information in the hope this can be fixed. 

In Thunderbird I have four e-mail accounts, three newsgroups and a local folder.
I have many saved folders in the local folder. Only one account will place my
sent mail in the correct folder (Not the default account). My default e-mail
account is used for the SMTP server- primarily due to issue with the University
of Phoenix's security protocols. In my case, I did not create a new sent folder.
I am using the original folder.

When I select sent mail to be sent to the sent folder in all four accounts, it
lets me save the setting, but will revert itself when I reopen the account. Only
one account retains the setting. The sent folder will remain empty.

Comment 4

13 years ago
This seems to work OK with UW IMAP, but not Dovecot. Dovecot appropriately sends back a TRYCREATE error (which Thunderbird should handle by trying to create the missing folder). 

UW IMAP's response to such an append is:
* OK [TRYCREATE] Must create mailbox before append
1 NO [TRYCREATE] APPEND failed: Can't append to mailbox mail/notafolder: no such mailbox

and dovecot's is (there is no untagged OK response):
1 NO [TRYCREATE] Mailbox doesn't exist: mail/nosuchfolder
QA Contact: front-end

Updated

10 years ago
Assignee: mscott → nobody

Updated

10 years ago
Component: Mail Window Front End → Networking: IMAP
Keywords: qawanted
Product: Thunderbird → MailNews Core
QA Contact: front-end → networking.imap
Summary: Sending mail (IMAP) with save to "Sent" folder (on server), with no "Sent" folder on the server -> error → Sending mail (IMAP) with save to "Sent" folder (on server), with no "Sent" folder on the server -> error "Permission denied."

Comment 5

10 years ago
Dovecot 1.0.15 are working just fine with 2.x tree didn't try with trunk.

Comment 6

5 years ago
Alexander's address is dead.

WFM per comment 5. But if anyone else sees this on a current version please speak up
Status: NEW → RESOLVED
Last Resolved: 5 years ago
Resolution: --- → WORKSFORME

Comment 7

5 years ago
I'm seeing this with Thunderbird v24.0. Steps to repro:

- Create new user account and log in
- Send an email
- Failure with "TRYCREATE Mailbox doesn't exist: Sent" (or something similar, don't remember the exact message)

Happy to capture any debugging information necessary. The other end is postfix 2.9.6 as MTA and dovecot 2.0.19 for IMAP. Problem was fixed by creating the "Sent" folder in Thunderbird.
You need to log in before you can comment on or make changes to this bug.