[Dogfood] A crash occurs when you select a newly received msg to display

VERIFIED DUPLICATE of bug 22001

Status

MailNews Core
Backend
P3
critical
VERIFIED DUPLICATE of bug 22001
18 years ago
9 years ago

People

(Reporter: Katsuhiko Momoi, Assigned: Phil Peterson)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
** Observed with 12/16/99 Win32 build **

I have seen this bug several times now in the last 2 days but now I can
reproduce this bug every time by following the steps below.

Basically, Mozilla crashes when you try to view a newly received
message under certain conditions. You need to follow the steps
carefully -- there may be other ways to reproduce this bug but
this is one sure way I know.

1. If you are already up, quit Mozilla and re-start.
2. Now start Mozilla and start Messenger.
3. Select an IMAP server. (Don't know if this is true with POP yet.)
4. Now select the last message in Inbox to display and see
   that it is loaded and displayed.
5. Now bring up a new mail Compose window.
6. Just compose any msg you want -- I use one line msg.
7. Then send it out to the very account you're now reading mail in.
8. Receive this msg by clicking on "Get Msg"
9. Now select this newly arrived msh to view.  This is when it crashes
   without fail if you follow these steps.

By the way after this crash if you re-start Messenger and go back to
the same message to display, the crash will not occur. This crash has to do
with dealing a newly arrived msg while you're viewing an exiting msg.

I have several Talkback dumps but they all look the same. Here's
one of them:

======================

 Trigger Type:  Program Crash

 Trigger Reason:  Access violation

 Call Stack:    (Signature = nsAddrDatabase::GetCardForEmailAddress 03474fac)




 nsAddrDatabase::GetCardForEmailAddress

[d:\builds\seamonkey\mozilla\mailnews\addrbook\src\nsAddrDatabase.cpp, line
2683]




 IMGLUE.DLL + 0xe305 (0x01bde305)





 AIMSTAT.DLL + 0x1959 (0x02881959)





 nsMimeXULEmitter::ProcessSingleEmailEntry

[d:\builds\seamonkey\mozilla\mailnews\mime\emitters\src\nsMimeXULEmitter.cpp,
line 994]




 nsMimeXULEmitter::OutputEmailAddresses

[d:\builds\seamonkey\mozilla\mailnews\mime\emitters\src\nsMimeXULEmitter.cpp,
line 906]




 nsMimeXULEmitter::WriteEmailAddrXULTag

[d:\builds\seamonkey\mozilla\mailnews\mime\emitters\src\nsMimeXULEmitter.cpp,
line 751]




 nsMimeXULEmitter::WriteXULTag

[d:\builds\seamonkey\mozilla\mailnews\mime\emitters\src\nsMimeXULEmitter.cpp,
line 678]




 nsMimeXULEmitter::OutputGenericHeader

[d:\builds\seamonkey\mozilla\mailnews\mime\emitters\src\nsMimeXULEmitter.cpp,
line 539]




 nsMimeXULEmitter::DumpSubjectFromDate

[d:\builds\seamonkey\mozilla\mailnews\mime\emitters\src\nsMimeXULEmitter.cpp,
line 558]




 nsMimeXULEmitter::Complete

[d:\builds\seamonkey\mozilla\mailnews\mime\emitters\src\nsMimeXULEmitter.cpp,
line 333]




 nsStreamConverter::OnStopRequest

[d:\builds\seamonkey\mozilla\mailnews\mime\src\nsStreamConverter.cpp, line 733]

 0x02aebdd0
 0x65206461

===================================
(Reporter)

Updated

18 years ago
Summary: A crash occurs when you select a newly received msg to display → [Dogfood] A crash occurs when you select a newly received msg to display
(Reporter)

Comment 1

18 years ago
Because this is a serious bug, I'm going to mark it [Dogfood].
We should try to fix this crash for M12 if at all possible.

Comment 2

18 years ago
Same as 22001, I believe.
(Reporter)

Updated

18 years ago
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
(Reporter)

Updated

18 years ago
Status: RESOLVED → VERIFIED
(Reporter)

Comment 3

18 years ago
This should be a duplicate of Bug 22001. So I'll mark it as
such. The steps I described above induce the crash all the time
and consistently. So you might want to follow these in reproducing the
bug. For me this is not a random crash.

*** This bug has been marked as a duplicate of 22001 ***
(Reporter)

Comment 4

18 years ago
Verified as duplicate.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.