header output format ignores signedness of constants

VERIFIED DUPLICATE of bug 20833

Status

()

Core
XPCOM
P3
normal
VERIFIED DUPLICATE of bug 20833
19 years ago
10 years ago

People

(Reporter: John Bandhauer, Assigned: Mike McCabe)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
the input...
const unsigned long eExtraFilter = 1<<31;
...produces the .h output...
enum { eExtraFilter = -2147483648 };

But because the const was declared unsigned this should be...
enum { eExtraFilter = 2147483648 };

In header generation the formattting code in do_const_dcl uses a '%d' regardless
of the signedness. There is code in typelib_const_dcl that takes the signedness
of contants into account.
(Assignee)

Updated

19 years ago
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE
(Assignee)

Comment 1

19 years ago
I have a fix for this one in my tree; it's also attached to 20833.  Marking as
dup.

*** This bug has been marked as a duplicate of 20833 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: xpidl → XPCOM
QA Contact: mike+mozilla → xpcom
You need to log in before you can comment on or make changes to this bug.