mass changing bugs to ASSIGNED with musthavemilestoneonaccept fails with a poor error message

RESOLVED DUPLICATE of bug 151360

Status

()

Bugzilla
Creating/Changing Bugs
--
critical
RESOLVED DUPLICATE of bug 151360
14 years ago
5 years ago

People

(Reporter: Andreas Höfler, Assigned: myk)

Tracking

Bug Flags:
blocking2.18 -

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b; MultiZilla v1.5.0.2Beta) Gecko/20030827 WebWasher 3.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.5b; MultiZilla v1.5.0.2Beta) Gecko/20030827 WebWasher 3.3

Changing multiple bugs at once, without choosing milestone (only default '---'
existing), to ASSIGNED fails.

Reproducible: Always

Steps to Reproduce:
1. "Change serveral bugs at once" (containing bugs from different products)
2. Choose some "NEW" and some "ASSIGNED"
3. Select "Accept tasks (change status to ASSIGNED)" but no milestone
("--do_not_change--")
4. "Commit"

Actual Results:  
...
Software error:
Can't use an undefined value as an ARRAY reference at
/usr/local/httpd/htdocs/taskzilla/process_bug.cgi line 874.
...


Expected Results:  
Either assigning bugs with default milestone, or (propably better) a nice
Bugzilla error page telling me:
"No milestone selected, if you can't select milestones, try to get only bugs
from a single product into the 'Change multiple'-List" (however this can be done)
(Reporter)

Comment 1

14 years ago
Uh, this also happens, if only bugs from one product are selected and a Target
Milestone is chosen. This is no good...

Comment 2

14 years ago
Okay, I see why this happens. I can reproduce it on cvs-tip.

There needs to be a musthavemilestoneonaccept error thrown for these mass-changes.

I think this is really "normal," but I saw justdave say elsewhere that all
"Software error" messages are critical.

-M
Severity: major → critical
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows 2000 → All
Summary: changing multiple bugs, some to ASSIGNED, with musthavemilestoneonaccept fails → mass changing bugs to ASSIGNED with musthavemilestoneonaccept fails with a poor error message
Version: unspecified → 2.17.6

Comment 3

13 years ago
*** Bug 262266 has been marked as a duplicate of this bug. ***
Flags: blocking2.18-
Whiteboard: will accept for 2.18 branch, but not blocking release
Target Milestone: --- → Bugzilla 2.18

Comment 4

13 years ago

*** This bug has been marked as a duplicate of 151360 ***
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
Whiteboard: will accept for 2.18 branch, but not blocking release
clearing target for resolved other than fixed, so they'll show up as untriaged
if they ever get reopened.
Target Milestone: Bugzilla 2.18 → ---
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.