If new email comes in while reading a message in the preview pane, the message scrolls back to the start

VERIFIED FIXED in Thunderbird0.5

Status

Thunderbird
Mail Window Front End
VERIFIED FIXED
14 years ago
14 years ago

People

(Reporter: steve, Assigned: Scott MacGregor)

Tracking

unspecified
Thunderbird0.5

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.0; H010818)
Build Identifier: Mozilla Thunderbird 0.3 (20030923)

When reading a long email in the preview panel, should new mail be downloaded 
(which happens frequently) the message will scroll back to the start.  I don't 
recall this happening in TB 0.1, but it's happening in 0.2 and 0.3.

I've seen the problem on both systems I use - XP and W2000

Reproducible: Always

Steps to Reproduce:
1 When reading a long email in the preview panel, should new mail be downloaded 
(which happens frequently) the message will scroll back to the start.  I don't 
recall this happening in TB 0.1, but it's happening in 0.2 and 0.3.

I've seen the problem on both systems I use - XP and W2000


Expected Results:  
Not scroll back - it's annoying!

Comment 1

14 years ago
Confirmed, on Linux/x86, recent cvs build (don't have precise version to hand).
IMAP inbox.
OS: Windows 2000 → All
Hardware: PC → All

Comment 2

14 years ago
*** Bug 222186 has been marked as a duplicate of this bug. ***

Comment 3

14 years ago
This behavior also occurs when viewing messages in their own window, not just
the preview pane.

I am running Mozilla Thunderbird 0.3 (20031013) on WinXP.

Comment 4

14 years ago
*** Bug 224626 has been marked as a duplicate of this bug. ***

Comment 5

14 years ago
*** Bug 223402 has been marked as a duplicate of this bug. ***

Comment 6

14 years ago
Also occurring in ThunderBird 0.4a 11192003, Win32 (WinME).
(Assignee)

Updated

14 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Thunderbird0.5

Comment 7

14 years ago
As might be expected, this also happens when a new message arrives, is
interpreted to be junk and is moved to the Junk folder without activating the
'new message' announcement.

In latest instance, was reading a message in its own pane using ThunderBird 0.4a
20031119 under WinMe.

Glad to see it's targeted for 0.5 .
I just hit this when downloading a large folder over IMAP.  The preview pane
scroll position resets to the top each time an email is downloaded in the
background for junk mail filtering, so this rendered the preview pane mostly
unusable for a good 5 minutes while a couple thousand emails downloaded in the
background.
(Assignee)

Comment 9

14 years ago
hmmm that sounds really weird. I wonder what would cause the docshell to reset
scroll position in the document....

Comment 10

14 years ago
*** Bug 230142 has been marked as a duplicate of this bug. ***

Comment 11

14 years ago
Slightly more careful examination, the 'event' that best synchronizes with the
change of scrolling is raising the Notification banner out of the system tray.
(Assignee)

Comment 12

14 years ago
Created attachment 139760 [details] [diff] [review]
the fix
(Assignee)

Updated

14 years ago
Blocks: 231959
(Assignee)

Comment 13

14 years ago
*** Bug 231902 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 14

14 years ago
fix on the trunk and the M4 branch.
Status: ASSIGNED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → FIXED
(Assignee)

Comment 15

14 years ago
*** Bug 231650 has been marked as a duplicate of this bug. ***

Comment 16

14 years ago
Comment on attachment 139760 [details] [diff] [review]
the fix

>+  var isAlreadyCollapsed = junkBar.getAttribute("collapsed") == "true";
We have .collapsed for this. (It's also a setter, while I mention it...)

>+  // simulate XOR
Since isJunk and isAlreadyCollapsed are both boolean then != works.

>+  return (isJunk && isAlreadyCollapsed) || (!isJunk && !junkBar);
!junkBar is meaningless here.
(Reporter)

Comment 17

14 years ago
Is fixed in the Mozilla Thunderbird 0.5a (20040128) build on Windows.
Status: RESOLVED → VERIFIED

Comment 18

14 years ago
*** Bug 238766 has been marked as a duplicate of this bug. ***
You need to log in before you can comment on or make changes to this bug.