[DOGFOOD] profile manager shows blank page & error looking for null.xul

VERIFIED FIXED in M13

Status

Core Graveyard
Profile: BackEnd
P1
major
VERIFIED FIXED
18 years ago
2 years ago

People

(Reporter: cls, Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT+] Fix ready and verified)

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
I removed .mozilla and attempted to create a profile from scratch.  When
prompted for the name of the new dialog, I deleted 'mozProfile' and inserted
'cls'.  The next dialog box that came up was blank with the exception of the
Cancel, Previous, Next, Finish buttons and the Mozilla Profile Manager banner.
According to lxr, there is no null.xul file in the tree.  The terminal output is
below.  My tree was updated from the tip at 22:49 EST 12/16 (tonight).  RH6.0 +
gcc 2.95.2 + binutils 2.9.1.0.25 + glib/gtk 1.2.5.

(gdb) prun
Breakpoint 1 at 0x804c3f5: file /opt/cls/mozilla/xpfe/bootstrap/nsAppRunner.cpp,
line 637.
main (argc=1, argv=0xbffff764)
    at /opt/cls/mozilla/xpfe/bootstrap/nsAppRunner.cpp:637
637       InstallUnixSignalHandlers(argv[0]);
nsNativeComponentLoader: autoregistering begins.
nsNativeComponentLoader: autoregistering succeeded
nNCL: registering deferred (0)
nsUnixToolkitService: Using 'gtk' for the Widget Toolkit.
nsUnixToolkitService: Using 'gtk' for the Gfx Toolkit.
NS_SetupRegistry() MOZ_TOOLKIT=gtk, WIDGET_DLL=libwidget_gtk.so,
GFX_DLL=libgfx_gtk.so
[New Thread 22336 (manager thread)]
[New Thread 22306 (initial thread)]
[New Thread 22337]
[Switching to Thread 22337]
[Switching to Thread 22306 (initial thread)]
initialized appshell
GFX: dpi=96 t2p=0.0666667 p2t=15 depth=16
WEBSHELL+ = 1
Got the event queue from the service
Calling gdk_input_add with event queue
Note: styleverifytree is disabled
Note: frameverifytree is disabled
WEBSHELL+ = 2
Note: verifyreflow is disabled
calling loadpage...
startPage:: newProfile1_1
got a request
JavaScript Error: ReferenceError: arguments is not defined
URL: chrome://global/content/wizardHandlerSet.js
LineNo: 105

got a request
JavaScript Error: ReferenceError: arguments is not defined
URL: chrome://global/content/wizardHandlerSet.js
LineNo: 105

WEBSHELL+ = 3
warning: property locale.all.ET_ET already exists
got a request
Opening file null.xul failed
WEBSHELL- = 2
Error: Can't load: resource:///chrome/profile/content/default/null.xul
(80004005)

Updated

18 years ago
Summary: profile manager shows blank page & error looking for null.xul → [DOGFOOD] profile manager shows blank page & error looking for null.xul

Comment 1

18 years ago
Yes, I see this too.  marking dogfood.

Comment 2

18 years ago
Note, I only see this after a clobber build.

Comment 3

18 years ago
reproduced on
ftp://sweetlou/products/client/seamonkey/unix/linux/2.2/x86/1999-12-17-08-M13/ne
tscape-i686-pc-linux-gnu.tar.gz

Steps to reproduce:
1. run ./mozilla -installer
2. press new
3. enter profile (or leave default)
3. press next
Actual results: blank screen comes up and hangs

Expected results: ProfileWizard should close and seamonkey launch
Next button should be disabled on this screen , and you should be allowed to
press previous/cancel or finish. If you press finish, profile gets created

Note: running ./mozilla (after deleting .mozilla) brought up wizard which
allowed for a profile creation and launch.  Invoking the wizard from the profile
manager with new was the only way I could reproduce this.  Also able migrate an
existing 4.x profile.

Updated

18 years ago
Severity: blocker → major

Comment 4

18 years ago
This can be reproduced with ./mozilla also.
After entering profile name or using default, pressing the next button causes
the hang, pressing finish creates the profile and launches.
Not a blocker

Updated

18 years ago
Whiteboard: [PDT+]

Comment 5

18 years ago
Putting on PDT+ radar.

Comment 6

18 years ago
M12  1999-12-17-10-M12/ does not exhibit this behavior-next button is disabled

This is on the M13 builds - first one I tested today-sorry,
Also seeing on Win95

Comment 7

18 years ago
*** Bug 22081 has been marked as a duplicate of this bug. ***

Comment 8

18 years ago
The following patch gets me through the error, but I did exit to shell after
filling in the profile (maybe another bug). Next start, mozilla ran beautifully.

syd


Index: wizardHandlerSet.js
===================================================================
RCS file: /cvsroot/mozilla/xpfe/global/resources/content/wizardHandlerSet.js,v
retrieving revision 1.2
diff -r1.2 wizardHandlerSet.js
105c105
<     ( arguments.length && nextButton ) )
---
>     ( window.arguments && window.arguments.length && nextButton ) )
108c108
<     ( arguments.length && !nextButton ) )
---
>     ( window.arguments && window.arguments.length && !nextButton ) )
113c113
<     ( arguments.length && finishButton ) )
---
>     ( window.arguments && window.arguments.length && finishButton ) )
116c116
<     ( arguments.length && !finishButton ) )
---
>     ( window.arguments && window.arguments.length && !finishButton ) )
121c121
<     ( arguments.length && backButton ) )
---
>     ( window.arguments && window.arguments.length && backButton ) )
124c124
<     ( arguments.length && !backButton ) )
---
>     ( window.arguments && window.arguments.length && !backButton ) )

Comment 9

18 years ago
The patch appears to be invalid, working with Ben and rginda on this...

Updated

18 years ago
Assignee: selmer → rgoodger

Comment 10

18 years ago
Ben, this is in your wizardHandlerSet.js file so I assume it's related to
changes you've made recently.
Status: NEW → ASSIGNED
I have a fix that appears to work on Windows 95 at least, and corrects some
unrelated dumbness on my part.

Can someone test/approve it for me? I'll created it as an attachment to this
bug.
Created attachment 3659 [details]
fixed wizardHandlerSet.js
(sorry bout all the spam..)

Comment 14

18 years ago
*** Bug 22197 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 15

18 years ago
Verified that the fix works under Linux/x86. r=cls

Updated

18 years ago
Priority: P3 → P1
Whiteboard: [PDT+] → [PDT+] Fix ready and verified
Target Milestone: M13

Comment 16

18 years ago
Ben, you can check the fix into the tip.

Comment 17

18 years ago
On M13 builds for Win 1999122109, NEXT button is not disabled last page, but
pressing it does not cause a problem-it just does nothing. You can press FINISH
and create a profile.
I am finding that you can only create one profile per run-probably not an issue
for most users, but found in testing renaming and deleting of profiles.

Comment 18

18 years ago
Ben, if this is checked in, can you mark this as fixed?
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
seems to be fixed now

(although people are reporting other, different problems ;)

Updated

18 years ago
Status: RESOLVED → VERIFIED

Comment 20

18 years ago
Linux build 1999122308
The original problem is fixed, I will log problem for other behavior I noted- ie
can only create one profile per run and next button not disabled.

Updated

18 years ago
Component: Profile Manager → Profile Manager BackEnd

Comment 21

18 years ago
Moving all Profile Manager bugs to new Profile Manager Backend component.
Profile Manager component to be deleted.
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.