scrollbars in iframes even if it has been disabled by attribute scrolling="no" and css-attribute overflow:none

RESOLVED FIXED in mozilla1.6alpha

Status

()

Core
Layout: HTML Frames
P2
major
RESOLVED FIXED
15 years ago
15 years ago

People

(Reporter: bjoern wolf, Assigned: dbaron)

Tracking

({regression, testcase})

Trunk
mozilla1.6alpha
regression, testcase
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [patch], URL)

Attachments

(4 attachments)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20030923 Firebird/0.7+
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20030923 Firebird/0.7+

On lauschmusik.de you can see many iframes.
With Firebird 0.6.1 there aren't any layout-problems with iframes and disabled
scrollbars but Firebird 0.7+ shows it.




Reproducible: Always

Steps to Reproduce:
1. Look at lauschmusik.de with Firebird 0.6.1
2. Use the Iframes
3. Look at lauschmusik.de with Firebird 0.7+
4. There are Scrollbars which should not be there.

Actual Results:  
Firebird shows scrollbars

Expected Results:  
Hide the scrollbars
I can reproduce this in 20030923 builds of Firebird (0.7+) and Mozilla (1.6a
trunk) on WinXP.

Comment 2

15 years ago
Created attachment 132095 [details]
Testcase

Comment 3

15 years ago
Confirming bug, 2003-09-23-05 trunk Linux

Mozilla 1.5RC1 works fine so I'm guessing it's a regression from bug 69355
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: regression, testcase
OS: Windows 2000 → All
Summary: firebird 0.7+ shows scrollbars in iframes even if it has been disabled by attribute scrolling="no" and css-attribute overflow:none → scrollbars in iframes even if it has been disabled by attribute scrolling="no" and css-attribute overflow:none
(Assignee)

Comment 4

15 years ago
The problem here is that nsHTMLFrameInnerFrame::GetScrolling depended on the
default value of 'overflow' being the constant 0.
(Assignee)

Comment 5

15 years ago
Er, no, that's not quite right.
(Assignee)

Comment 7

15 years ago
taking.
Assignee: frame → dbaron
Priority: -- → P2
Hardware: PC → All
Whiteboard: [patch]
Target Milestone: --- → mozilla1.6alpha
(Assignee)

Updated

15 years ago
Attachment #132108 - Flags: superreview?(bzbarsky)
Attachment #132108 - Flags: review?(bzbarsky)
(Assignee)

Comment 8

15 years ago
Created attachment 132110 [details]
IFRAME testcase
(Assignee)

Comment 9

15 years ago
Maybe it's not worth making -moz-scrollbars-vertical /
-moz-scrollbars-horizontal do that since ConstructRootFrame doesn't transfer
that information to the scrollbars in any way...
(Assignee)

Comment 10

15 years ago
Created attachment 132113 [details]
FRAMESET/FRAME testcase
Comment on attachment 132108 [details] [diff] [review]
patch

>Index: content/html/content/src/nsGenericHTMLElement.cpp

>+nsGenericHTMLElement::MapScrollingAttributeInto
....
>+  // bgcolor

This comment seems out of place.

>+      PRInt32 mappedValue;

This will lead to a "may be used uninitialized" warning because of the default:
case.  Not sure how much we care about that, really.

r+sr=bzbarsky with the first of those two nits picked (I really don't care
about the second one).
Attachment #132108 - Flags: superreview?(bzbarsky)
Attachment #132108 - Flags: superreview+
Attachment #132108 - Flags: review?(bzbarsky)
Attachment #132108 - Flags: review+
(Assignee)

Comment 12

15 years ago
Fix checked in to trunk, 2003-09-24 20:55 -0700.  (Both problems fixed.)
Status: NEW → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → FIXED
(Reporter)

Comment 13

15 years ago
sorry for that but as for me it seems not to be fixed.
the css-attribute "overflow" is still ignored.

so if you add the tag-attribute "scrolling=no" AND the
css-attribute "overflow:hidden" the css-style overrides the
tag-attribute (right behaviour) but does _not_ behave
right with displaying these bars ;)

(as i tested this morning firebird recognizes the css-overflow
parameter "noscroll" and hides the scrollbars. but this param
isn't w3c-compliant. seems that the browser matches this css-overflow-values
against tag-attribute-values?)


i tried the latest trunk which should have been fixed:
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.6a) Gecko/20030924
Firebird/0.7+
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 14

15 years ago
A build from the 24th would not have the fix.

scrolling="no" and 'overflow:hidden' should have the same effect.  If you still
have a problem then please attach a testcase when you reopen the bug.
Status: REOPENED → RESOLVED
Last Resolved: 15 years ago15 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.