Last Comment Bug 220196 - prevent multiple instances
: prevent multiple instances
Status: RESOLVED WORKSFORME
:
Product: Thunderbird
Classification: Client Software
Component: Mail Window Front End (show other bugs)
: unspecified
: x86 Windows XP
-- enhancement with 5 votes (vote)
: ---
Assigned To: Scott MacGregor
:
:
Mentors:
: 244434 (view as bug list)
Depends on:
Blocks: 267335
  Show dependency treegraph
 
Reported: 2003-09-24 11:21 PDT by Robert Mohr
Modified: 2008-03-13 14:17 PDT (History)
11 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description User image Robert Mohr 2003-09-24 11:21:43 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5a) Gecko/20030728 Mozilla Firebird/0.6.1
Build Identifier: Thunderbird 0.2

If Mozilla Thunderbird is running and I attempt to run a new instance, I should
have my focus switched to the current instance.  For many types of applications
this is annoying, but not so much for an email program.  For those who wouldn't
want this, it could be disabled if the -profilemanager switch is set (allowing
one instance for each profile).

Reproducible: Always

Steps to Reproduce:
Comment 1 User image Benedikt Kantus 2004-05-23 09:29:09 PDT
*** Bug 244434 has been marked as a duplicate of this bug. ***
Comment 2 User image Daniel Drucker 2004-10-22 20:57:56 PDT
Every time I hit the "Mail" button on my keyboard, a new Thunderbird window is
created. I would like instead for the focus to be switched to the current
instance, as that is the standard expected behavior of other email applications.

I can see the merits of the opposing view, but I see no reason why this
shouldn't at least be an optional behavior.
Comment 3 User image Riccardo Cretti 2005-04-03 03:14:10 PDT
Using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8b2) Gecko/20050401
Firefox/1.0+ if I press on mail button of my keyboard Thunderbird is not
launched more than once, after that the instance already opened gets the focus
(if it was minimized it shows on the screen in a strange size, not showing
maximized).
There is still the problem that a double click on a folder open a new instance
of Thunderbird.
It's an awful thing and should be fixed; right now the only way to avoid it is
to install the No New Window On Double Click extension.
Comment 4 User image proton 2005-04-22 00:00:37 PDT
thunderbird 1.0.2 (20050320) have this bug 
generally i minimize TB to tray & i hate to have sometimes 4-5 windows running
Comment 5 User image David A. Cobb 2005-05-18 15:33:11 PDT
Is this another symptom of the same thing:
I have Thunderbird running.  In Firefox, I click on a mailto:...  link.

Instead of popping up with the composition window (from the active instance) it
pops up the Profilemanager because my profile is busy with the active instance.

IF SO, please broaden this bug to OS=All, as I am running Linux.
Comment 6 User image Alexander Ivanchev 2005-07-04 13:34:53 PDT
+1 to #2's comment, thing is I also use a minimize to tray extension, and thus,
I sometime end up with 3 running instances ;-) (pretty annoying usability-wise).
Comment 7 User image Morpurgo.nl 2005-07-05 12:38:36 PDT
This bug is known from before 2004-05-23 but is there a fix now to open always
one instance? 
Comment 8 User image Jeroen Zomer 2005-07-14 05:37:58 PDT
Reproducable:

Open and minimize TB
Open FF and choose Tools>Read Mail

Another instance is spawned
Comment 9 User image Wayne Mery (:wsmwk, NI for questions) 2005-09-26 05:07:40 PDT
this is fixed for me - WFM XP version 1.6a1 (20050920)  version 1.6a1 (20050920)
(got fixed by TB somewhere, sometime, but I can't find the bug)

Does it now work for you?  Jeroen, et al


NOTE HOWEVER, these steps exhibit another bug - the window size is not
remembered if I start maximized and then minimize.

Steps to reproduce:
1. maximize TB
2. minimize TB
3. switch to FF
4. tools > read new messages

or for step 4 use:  start > ... > mozilla thunderbird

actual results: TB is restored as a small window
expected results: TB restored to maximized window state
Comment 10 User image Morpurgo.nl 2005-09-26 08:10:22 PDT
This bug is fixed for me, don't know how!

Tested on: Ms Win XP Pro SP2,
TB 1.5 beta 1(20050908),
Minimize to tray 0.0.1.2005091606+
FF 1.0.7 Gecko 20050919

Test:
1)When minimized to tray and clicking the e-mail button in FF the active
instance opens, no new instance is produced.
2) When minimized to tray and clicking for an instance to open on the windows
task bar (next to start)the active instance opens, no new instance is produced.
3) When minimized to tray and clicking on the shortcut on my desktop the active
instance opens, no new instance is produced.
Comment 11 User image mudler 2005-12-13 21:21:08 PST
This bug is semi fixed it seems, but not completely fixed.

I'm running Thunderbird version 1.5 (20051025) (RC1), on Windows XP Pro, with SP2.

If you have an instance of Thunderbird open already, and click on icon it will usually just bring up focus of running instance, BUT you can run multiple instances of thunderbird still like this:

1. Make sure no instances of thunderbird running.
2. Click on thunderbird icon very quickly a few times.

Expected result: One instance run only.
Actual result: multiple instances are run.

I have gotten up to 5 copies running before, I'm sure you could get more.

Seems to be a small race condition that allows for multiple copies of thunderbird instances to run.
Comment 12 User image skreemer7 2006-05-07 14:44:34 PDT
I have Thunderbird 1.5 with xp pro sp2, and the newest minimizetotray version. My problem is that if I double click an email and open it in a separate window, then whenever I try to close or minimize it, it goes to the tray and then I have to find which one it is before I can close the particular email, since the icons for it and the main window look the same. Is there any way to actually close the message windows but have the main window go to tray?
Comment 13 User image Frank 2006-11-19 03:37:15 PST
Apparently this is fixed, but I don't like it this way. It should do one instance *per profile*. I have two shortcuts to two TB profiles, one for my mail and one for my wifes mail. We want to be able to run both of them, but that seems impossible now.
Comment 14 User image Morpurgo.nl 2006-11-19 04:13:37 PST
(In reply to comment #12)
> I have Thunderbird 1.5.0.8 with xp pro sp2, and the newest minimizetotray version 0.0.1.2006102615+ and FF 2.0

I can reproduce the bug still exists, sometimes there are 5 to 10 icons next to the clock from TB or an open TB email. You can not see the difference and closing the wrong one is done to simple.

Comment 15 User image Jorge Vidal Wulff 2007-06-03 03:27:13 PDT
Same thing here.
If There's no TB window running and I click on "mailto:" link or press "new message" or "Ctrl-M", then the main window appears ALONG with the compose window. If I disable the extension on TB, automatically works fine again.
Comment 16 User image Jorge Vidal Wulff 2007-06-16 14:30:15 PDT
I just installed TB 2.0.0.4 and the bug is still there.
Comment 17 User image Jorge Vidal Wulff 2007-07-28 20:00:10 PDT
additionally, installing the no new window extension doesn't solve the problem.
TB 2.0.0.5
Comment 18 User image Tuukka Tolvanen (sp3000) 2008-03-13 13:52:10 PDT
wfm 1.5.0.14 xp, and trunk linux. The original issue is most certainly fixed / wfm for a long long long time now. If there are remaining / other related issues, please file separate bugs on specific cases.

->wfm

Note You need to log in before you can comment on or make changes to this bug.