URL (location) bar encode search before pass arguments to search engine

RESOLVED DUPLICATE of bug 193178

Status

SeaMonkey
Search
--
minor
RESOLVED DUPLICATE of bug 193178
14 years ago
9 years ago

People

(Reporter: Felix Cuello, Assigned: shliang)

Tracking

({helpwanted})

Trunk
x86
Linux
helpwanted

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030624

When you try to search something using LOCATION BAR search with (i.e. google)
and you put something like "c++" the search engine receives:
"c  ", because + in URL location bar means BLANK SPACE coded.

The result in the search engine must be "c++".


Reproducible: Always

Steps to Reproduce:
1. configure Mozilla to use www.google.com search engine
2. put "c++" at URL location bar
3. click over 'Search google for "c++"'


Actual Results:  
The result in the search engine are "c  "

Expected Results:  
The result in the search engine MUST be "c++"

I'm using Debian/unstable
Keywords: helpwanted

Comment 1

14 years ago
WFM on all versions I checked (incl. 1.5rc1 and 1.2.1)

*** This bug has been marked as a duplicate of 193178 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → DUPLICATE
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.