text-decoration:none does not suppress underline when multiple selectors apply

RESOLVED INVALID

Status

()

Core
Layout: Text
RESOLVED INVALID
15 years ago
15 years ago

People

(Reporter: herman, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916

CSS sets blue underline in <body>. One CSS declaration sets black no-underline
for <p>, another CSS declaration sets 200% font height for <p class="four">.
Both declarations are being applied because black (from declaration 1) and 200%
(from declaration 2) are seen in the <p class="four"> content. However, the
text-decoration:none in declaration 1 is ignored and the text remains
underlined. A similar test case at http://4.23.88.192/wit/bugs/test2.xhtml that
uses italics instead of underlines works as expected. 

Reproducible: Always

Steps to Reproduce:
1. visit http://4.23.88.192/wit/bugs/test1.xhtml
2.
3.

Actual Results:  
Saw underlines when none were expected.

Expected Results:  
Apply the text-decoration:none property that accompanies the correctly applied
black color.
Our behavior is correct.  See http://www.w3.org/TR/CSS21/text.html#q3
Status: UNCONFIRMED → RESOLVED
Last Resolved: 15 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.