Closed Bug 220293 Opened 17 years ago Closed 17 years ago

Allow more than one sorting criteria

Categories

(SeaMonkey :: MailNews: Message Display, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

(Not tracked)

VERIFIED DUPLICATE of bug 57898

People

(Reporter: jhouse, Assigned: sspitzer)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.5) Gecko/20030916

Currently, sorting can be done by info columns about the various e-mails in a
folder.  Sorting by any one column does not guarantee a unique ordering of
e-mails.  (7 columns only provide vague categories such as read/unread) Because
of this, there is room for the resulting sort to not match the user's expectations.

As an example of what I personally want to see when I click on a folder:
1.  All unread messages
2.  All labeled messages (ie. important first, then work, then personal)
    (Most recent messages first)
3.  All other messages (read,unlabeled)
    (Most recent messages first)

The sorting criteria for this would be
Primary Sort: Unread
Secondary Sort: Label
Terciary Sort: Date


Fixed Number of Categories:
Read:            2 categories
Status:          4 categories (at least)
Flag:            2 categories
Label:           5 categories (by default)
Junk:            2 categories
Priority:        5 categories
Unread:          2 categories

Other items that might benefit from secondary sorts:
Thread, Subject, Sender, and Size (if quantized well)

Unique sorting criteria's (ie must be last criteria applied)
Date, Order Received

Reproducible: Always

Steps to Reproduce:
N/A
Actual Results:  
N/A

Expected Results:  
N/A
Summary: Feature Request: Allow more than one sorting criteria → Allow more than one sorting criteria

*** This bug has been marked as a duplicate of 57898 ***
Status: UNCONFIRMED → RESOLVED
Closed: 17 years ago
Resolution: --- → DUPLICATE
v
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.