unable to open an attachment from within an email in an imap folder

RESOLVED INCOMPLETE

Status

--
major
RESOLVED INCOMPLETE
15 years ago
9 years ago

People

(Reporter: smaster44, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

15 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20030924
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20030924

I have received an email with a gif attachement.
I try to right-click on it and choose open. when a windows does come up, it is
looking at imap://mymailboxnamehere/ and then a bunch of funny characters.
I am unable to see the attachment in the mozilla browser window that came up.

Reproducible: Always

Steps to Reproduce:
1. receive an email with a gif in it
2. try to open the gif attachment by double clicking on it, or right-clicking on
it and choosing open.


Actual Results:  
window opens up and it is unable to view/find the file to show content

Expected Results:  
Mozilla should have been able to show the attachment. since this is a gif, gif's
are viewable within a browser window.

Comment 1

15 years ago
I tried to reproduce this.
Mozilla opens the window, and shows the gif file, but it keeps loading the page
forever. Even if you press the stop button it doesn't stop. So maybe there is a
problem here.

I'm using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.6a) Gecko/20030925.
(Reporter)

Comment 2

15 years ago
for me the gif was never seen.

Comment 3

15 years ago
I tried this with a 1.7a build - it worked fine. If it doesn't work for you in
1.7, or 1.6 final, please let me know. thx.
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 4

14 years ago
I'm seeing this exact same behavior in a Linux gtk2 build Mozilla/5.0 (X11; U;
Linux i686; en-US; rv:1.8a3) Gecko/20040828

Comment 5

14 years ago
Seth Master, Lonnie Freeman: which IMAP server are you receiving mail from? In 
particular, is it a Microsoft Exchange server?  (bug 92111, bug 107221)

Comment 6

14 years ago
No, its a Linux server, running (i think) Courier IMAP and Exim.
Product: MailNews → Core
sorry for the spam.  making bugzilla reflect reality as I'm not working on these bugs.  filter on FOOBARCHEESE to remove these in bulk.
Assignee: sspitzer → nobody
Filter on "Nobody_NScomTLD_20080620"
QA Contact: stephend → attachments
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core

Comment 9

9 years ago
lacks testcase. 
please reopen if you still see problem using verison 3
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.