If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Necko has problem with two Content-type: headers (??)

VERIFIED WORKSFORME

Status

()

Core
Networking
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: John Morrison, Assigned: Gagan)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [PDT-])

(Reporter)

Description

18 years ago
From n.p.m.seamonkey :

|  Subject: unable to see http://www.eturnia.findhere.com/
|     From: Henrik Gemal <gemal@dk.net>
|
|  I can see it with IE4 an NS but todays build of Mozilla seem to die...

Using 19991215 WinNT, if I go to http://www.eturnia.findhere.com/
Mozilla just sits and spins (but the URL is live in Nav 4.7).

However, http://www.eturnia.findhere.com is a one-frame frameset that
points the single frame to http://members.xoom.com/Eturnia/.

If I go to http://members.xoom.com/Eturnia/, Mozilla throws up an
"application/x-unknown-content-type" (but again this is loadable
content in Nav 4.7

Using 'GET' from libwww-perl for http://members.xoom.com/Eturnia/, I
get the following (notice the two Content-Type: headers -- it's the
only odd thing that I notice).

qsilver1% GET -e -s -S -d http://members.xoom.com/Eturnia/
GET http://members.xoom.com/Eturnia/ --> 200 OK
Connection: close
Date: Fri, 17 Dec 1999 15:52:02 GMT
Accept-Ranges: bytes
Server: Apache/1.2.5
Content-Length: 1897
Content-Type: text/html
Content-Type: text/html; charset=iso-8859-1
ETag: "1082976-769-3844f62c"
Last-Modified: Wed, 01 Dec 1999 10:19:24 GMT
Client-Date: Fri, 17 Dec 1999 15:46:03 GMT
Client-Peer: 206.132.185.167:80
Title: Eturnia
X-Meta-Author: Sean Vindahl
X-Meta-GENERATOR: Mozilla/4.5 [en] (Win95; I) [Netscape]

qsilver1%

Here's GET for the frameset page: http://www.eturnia.findhere.com/

qsilver1% GET -e -s -S -d http://www.eturnia.findhere.com/
GET http://www.eturnia.findhere.com/ --> 200 OK
Connection: close
Date: Fri, 17 Dec 1999 10:58:56 GMT
Server: Apache/1.3.9 (Unix) PHP/3.0.12
Content-Type: text/html
Client-Date: Fri, 17 Dec 1999 15:51:56 GMT
Client-Peer: 208.231.31.106:80
Title: The official Eturnia site
X-Meta-Description: This is the official Eturnia © site of the band who's inspir
ed by artist like Blümchen and Dune
X-Meta-Keywords: Eturnia

qsilver1%

Comment 1

18 years ago
*** Bug 21605 has been marked as a duplicate of this bug. ***

Comment 2

18 years ago
I believe the second content-type is just coming from the interpretation of the
META tags. I have loaded many pages in Mozilla that contain these tags without
ill effect. It is interesting that both this bug and bug 21605 both are on Xoom.
maybe someone needs to investigate a little more deeply what is going on with
Xoom's server.

Updated

18 years ago
Target Milestone: M13

Comment 3

18 years ago
charset= again?

Comment 4

18 years ago
I've noticed this behavior with XOOM sites also.  If you add a _XMCM  and
the exact filename into the url like so
http://members.xoom.com/_XMCM/Eturnia/Index.htm the page renders in Mozilla.
Hope this helps a little.
(Assignee)

Comment 5

18 years ago
adding judson to cc list.
(Assignee)

Updated

18 years ago
Target Milestone: M13 → M14

Comment 6

18 years ago
http://www.eturnia.findhere.com/ works for me on winnt
(Reporter)

Comment 7

18 years ago
The content for http://www.eturnia.findhere.com/ _was_ a single frame frameset
that pointed through to http://members.xoom.com/Eturnia/ . I had problems
(likely related) in going to either URL (as noted above).

Today, http://www.eturnia.findhere.com/ loads find, but the content has
changed to a vanilla HTML page, promising to be back Real Soon Now. (And
perhaps the Networking problem I noted previously has already been solved).

**However**, today if I go to http://members.xoom.com/Eturnia/ I get a rather
nasty *crash* in XPCOM.DLL. (With the limited Wintop tool, apparently,
mozilla's footprint starts zooming by ~6MB per second! until VM is exhausted --
I don't entirely trust Wintop's numbers, but something has, uh, "gone wrong").
2000011108 on win95.

Should I file a new bug for this, or do you want to see if you
(gagan|valeski|tever) can get a stack trace, and find a new owner for the
crasher.

Comment 8

18 years ago
hmm. a new bug should be filed, but http://members.xoom.com/Eturnia/ loads just
fine for me on my winnt build.
(Reporter)

Comment 9

18 years ago
The other bug is filed as bug #23777
*** Bug 24500 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 11

18 years ago
Marking dependent on bug #23777 (the original problem may be gone, but this 
frameset keeps finding a brand new way to fail ...). See #23777.
Depends on: 23777

Updated

18 years ago
Keywords: beta1

Comment 12

18 years ago
pdt - please verify what the remaining problem is

Comment 13

18 years ago
Adding [NEED INFO] to Status Summary.
Whiteboard: [NEED INFO]
(Reporter)

Comment 14

18 years ago
It is possible that the original problem for this URL is gone, but bug 23777
blocks this bug. The behaviour of this page has morphed several times. It 
currently behaves as noted by me Jan 21 (and retested with Feb 03 build, win95) 
on bug 23777 -- the frameset comes up completely blank. [I expect that when bug 
23777 is resolved, then this bug will also be defunct].
Whiteboard: [NEED INFO] → [NEED INFO] some info added feb 04

Updated

18 years ago
Whiteboard: [NEED INFO] some info added feb 04 → [PDT-]

Comment 15

18 years ago
Okay. Bug #23777 is fixed and the original bug reported is no longer an issue.

(There is a DOM bug that may throw up an alert, but that is a different problem
-- see bug #30627). 
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 16

17 years ago
Verified
Platform: PC
OS: Windows 98
Mozilla Build: 2000101020 M18 Trunk Build
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.