ftp:// or file:// - tree view versus old-style directory listing should be selectable

RESOLVED INVALID

Status

SeaMonkey
General
--
major
RESOLVED INVALID
14 years ago
13 years ago

People

(Reporter: Jack Angel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

14 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030819
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030819

i hate the tree-view file browser! (ftp too)
and somehow it's now always appearing (i loved directory listings which were before)
the biggest flaw is that i can't copy the link from this bitchin' treeview
for users like me, you should make this configurable - some people would use the
tree-view, some - directory listing. there should be an option for this!

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
Um.

We have this.

Look under Preferences | Debug | Networking.
(Reporter)

Comment 2

14 years ago
That's good that the optin exists. But:
If only I had debug under preferences. I compiled Mozilla myself, and IIRC with
--disable-debug.
Anyway, such option shouldn't be in debug section. It's a mainstream UI
configuration option and should be placed somewhere in preferences/navigator, I
suppose.
New profiles always default to HTML-dir listings.

Without having Mozilla open, what's the value of this in prefs.js:

user_pref("network.dir.format", 3);

If it's '3', try 2 or 1, instead.

As for where this UI belongs, the decision was made a while back... 
The debug panel is removed in milestone builds.

The default value of the pref is indeed the "old-style" listing (you must have
changed it for that profile in the past).

And the reason the pref is "debug" is because the new-style listing is not yet
good enough for consumption by users.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 14 years ago
Resolution: --- → INVALID
(Reporter)

Comment 5

14 years ago
i don't remember changing this pref before, but thanks anyway
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.